Support » Plugin: All In One WP Security & Firewall » Drag and Drop and another error

  • Resolved Syxguns

    (@syxguns)


    I can’t seem to drag and drop modules from the front end of WP with the AIO activated. Is there a feature I can disable to allow for this?

    Also I gave someone admin rights to diagnose the issue, because I didn’t think it was plug-in related and when they logged in they received the following error

    Catchable fatal error: Object of class WP_Error could not be converted to string in /XXXX/XXXXXXXX/XXXX/XXXXXX/wp-includes/formatting.php on line 4239

    Lines 4238 to 4245 of formatting.php

    function wp_strip_all_tags($string, $remove_breaks = false) {
    	$string = preg_replace( '@<(script|style)[^>]*?>.*?</\\1>@si', '', $string );
    	$string = strip_tags($string);
    
    	if ( $remove_breaks )
    		$string = preg_replace('/[\r\n\t ]+/', ' ', $string);
    
    	return trim( $string );

    I personally haven’t had or seen these errors, but when I disabled the plug-in AIO everything was working great again.

    https://wordpress.org/plugins/all-in-one-wp-security-and-firewall/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi can you disable all Firewall rules? Then carry out another test to see if you can drag and drop again from the front end? If you can then you know one of the Firewall settings caused this issue.

    Start enabling one by one the Firewall features and at the same time testing to make sure you can still drag and drop from the front end.

    The error messages seems to be related to some cache function. Do you have a cache plugin installed?

    Turned off all Firewall settings and still can’t drag and drop modules from the front end. Disabled Sucuri as well, with no joy. However, if I deactivate the plugin I can drag and drop.

    I have ZenCache, which may have caused the error above. I just can’t figure out why it happened, unless he was using a wordpress backdoor. I block all of that stuff.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    The only suggestion is to disable all security plugin options. Then start enabling one by one and testing at the same time. To tell you the truth this is the first I troubleshoot an issue like this. I have never heard of something like what is happening to you right now.

    ZenCache plugin probably caused the error message like the one you see above.

    Can you elaborate a bit more with the following comment.

    unless he was using a wordpress backdoor. I block all of that stuff.

    Can you elaborate a bit more with the following comment.

    unless he was using a wordpress backdoor. I block all of that stuff.

    You can’t log into my site with dropzonecc.com/wp-admin you will get a 404 error page because I’ve renamed it. I did that because of all of the people trying to hack into my site. I stopped it almost dead. If you use the site the way it’s suppose to be used you will not get errors, at least I haven’t had any errors on my site.

    I’ll try turning off features one at a time. I’ll update this post if I am able to find an answer.

    Plugin Contributor mbrsolution

    (@mbrsolution)

    Hi, that is good to see that you use the Brute Force Rename Login Page feature. Did you also provide the secret login to your other admin user?

    In regards to your comment.

    If you use the site the way it’s suppose to be used you will not get errors, at least I haven’t had any errors on my site.

    Are you referring to the normal login using wp-admin instead of the secret word?

    I didn’t have Brute Force enabled at the time, and changed all of the login screens back to normal. I double checked everything and saw that I could access all pages, including wp-login and wp-admin without an issue, but for some reason he could not. That is when I disabled AIO to see if he could get on.

    Of course he was getting on my site to find out what the issue was. I disabled the plugin and I could drag and drop again, so he never got on my site.

    I’ll run through the settings tomorrow and see if I am able to figure out which setting it is that was causing the issue. Not to mention that I could have messed up my page structure with all of this playing around!! LOL

    @mbrsolution
    Okay I tracked down the culprit in this case, and thought I should let you know if this situation arises again. First I am using Themify to do all my developing, but there are other front end developers as well.

    The problem resided in Miscellaneous/Copy Protection

    As soon as I turned that off, leaving on Everything else I could drag and drop again from the front end.

    By the way, I tested your Brute Force with the plugin and was not happy with it. I customize all of my login pages and use “Lockdown WP” to change the wp-admin to my own hidden page. The one feature I hate about wordpress is the boring white login.

    Off to draw and develop my custom 404 error page!

    If you like you may check out my site at http://www.dropzonecc.com

    Topic Resolved,
    Thanks for your suggestions to get it figured out!

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Drag and Drop and another error’ is closed to new replies.