[resolved] Draft post not saving new edits (5 posts)

  1. vhilaire
    Posted 5 years ago #

    I wrote a post and then saved it as a draft a few days ago. I came back to the post today to add new content & edits. I hit Save Draft and it reverted back to the original content I had when I first created the post. All of the edits I had just made were gone.

    Under posts revisions every time I added the new copy again and hit Save, it lists the revisions under the date I first wrote the post and not today's date, with the new edits.

    This is a big problem. Any ideas on how to fix?

  2. esmi
    Forum Moderator
    Posted 5 years ago #

    Does your hosts limit the size of your database? Have you reached that limit?

  3. vhilaire
    Posted 5 years ago #


  4. esmi
    Forum Moderator
    Posted 5 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Eleven theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    - re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress.

  5. vhilaire
    Posted 4 years ago #

    I did all of that and it's still not saving new edits to published posts and drafts.

    I went to into my database manager and repaired the tables and that seems to have fixed the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic