Support » Plugin: Duplicator - WordPress Migration Plugin » Downloading the installer results in opening the source code in my browser

  • Resolved shakarum

    (@shakarum)


    Hi

    I’m trying to download the installer.php through the packages screen but when I press on the button it just opens the source code itself in my browser. No download popup window.
    That happens both in chrome and firefox.
    Tried to disable .htaccess File In Storage Directory with no help.

    Any ideas?

    Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @shakarum,

    Thanks for the feedback! There are a few items in the FAQ that may provide a solution to this issue, this one may get you going.

        – Why can’t I download files / see a 404.3 / get a corrupted installer?
        – https://snapcreek.com/duplicator/docs/faqs-tech/#faq-package-200-q

    Let me know if this helps~

    Solution 3 (download via FTP) is the only workaround that works, however I still need to rename the file manually after the download, and I also read posts in this forum in which users reported that when they tried to install those manually-downloaded files, the installation failed.
    To be honest, there are additional tools in WP that do the same job as duplicator, without all those workarounds, which frankly make it look a bit amateurish.

    Thanks

    Plugin Author Cory Lamle

    (@corylamleorg)

    Hey @shakarum,

    We currently run the plugin on dozens of different hosts and have not been able to reproduce the issue, I believe just a small amount of budget hosts have the issue and it seems to be related with how they allow mime types to be served up.

    If you want to submit a support ticket for this issue I can have a closer look at your setup to see if we can get around the issue on your server. If so please provide a link to this thread when submitting the ticket.

    Thanks~

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Downloading the installer results in opening the source code in my browser’ is closed to new replies.