Support » Plugins » Download Stats not working podPress

  • Resolved rajaito


    WordPress Version 3.1.2
    podPress Version

    There are no download stats next to file on front end.
    There are no podcast files or stats shown on dashboard.

    – I am able to post a url to an mp3 file on my server.
    – The audio file plays using the built in player.
    – I have tried this with different posts. The no stats problem persists.
    – I am using “Use WP permalinks” in podPress settings.
    – I can find no reference to podpress anywhere in my database.
    (I was expecting to find something with this prefix: wp_podpress_)

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thank you for your diligent and thorough report!

    You are right. podPress creates usually to db tables wp_podpress_stats and wp_podpress_statcounts. Further podPress creates these tables on activation and does not check for them later e.g. in the moment when you activate the stats feature.
    The problem seems to be that the type of the db tables is hardcoded in podPress and if the other tables have a different type then the db query will not create the tables.

    I guess that is the problem in your case. (I guess that the other tables of your blog have not the type MyISAM?)

    But the current Development Version has already a patch for that problem and controls also whether or not the stats tables exist when the stats features gets enabled and creates the tables if necessary.
    Or you may wait a little bit. I will release that Dev version as today.


    Tim, thank you so much for a speedy response. It is 2011 and you have dispelled the rumor that “this plugin has been abandoned since 2007”.

    I have installed the update you have released. However, the problem seems to be the same. No download counts or dashboad stats are appearing for already published podcsts. After I post this, I will attempt to publish a new podcast to see if I get the desired result.

    To answer your question about the other tables in my database, all of them say “MyISAM” under the type column.

    One thing I didn’t mention in my previous post was that at one point I tried to uninstall podPress completely using the plugin uninstaller. I was hoping that when I installed it again it would recreate the database. This didn’t work and in fact, when I reinstalled podPress, my previous podcasts magically came back! Leading me to believe, there is actually some database recording going on somewhere, despite the fact I cannot find it.

    I have the phpmyadmin plugin installed. I would be happy to give you access to my admin area if you think it would help you diagnose the problem.


    Posting a new podcast gets the same results. NO STATS

    Do I understand it right that you are using now?
    (If not, install this version.)
    Deactivate the stats feature. Save the settings. Activate stats feature and save the settings. Afterwards take a look at your db tables wp_podpress_stats and wp_statcounts should be among them again.
    (podPress creates the tables only when you activate the stats feature. Previous version create these tables only on the first installation of podPress. If old settings are in the db then previous podPress versions would skip the part with the db tables.)

    Yes, I did install and your last instructions have indeed created two database entries: wp_podpress_statcounts & wp_podpress_stats and also has solved the problem!

    I now have front-end download counts and dashboard stats.

    Thank you Tim. Long live podPress!

    Tim, I hate to dig up an old post but I am working on my site again and as it turns out I am having a similar issue with podpress. I still have the wp_podpress_statcounts & wp_podpress_stats entries. I also have published 52 podcasts, however the database is only showing the first 21 that I uploaded when I was using WP 3.1.2.. I have tried to disable and re-enable the stats. I have also re-saved my permalinks using the /%postname%/ method.

    All new podcasts are not being added to the database. What is your advice? Thanks.

    wordpress 3.3.1

    Nevermind… I figured out the podpress does not make an entry in the database until you hit play at least once.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Download Stats not working podPress’ is closed to new replies.