Support » Plugin: WP Photo Album Plus » Download spin without download and links missing

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Jacob N. Breetvelt

    (@opajaap)

    It looks there are too many photos in the album. Check the server error log to see what goes wrong.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    It is most likely a timeout. The timelimit will be increased in the next version ( 6.3.7 )

    Okay, 6.3.7 goes further and will package 50-60 photos. And the popup error message is very helpful.

    Thank you.

    Is there harm in setting the timeout even higher?

    Hmmm, I pushed max_execution_time to 110 and default_socket_time to 120, still had to limit IX A-5 to 55 so I suspect the new Ajax timeout is still the limiting factor?

    I’m up to 150 photos before timeout now.

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    Do the following:

    delete …/wp-content/plugins/wp-photo-album-plus/js/wppa-ajax-front.min.js
    From now on …/wp-content/plugins/wp-photo-album-plus/js/wppa-ajax-front.js will be loaded.

    Edit …/wp-content/plugins/wp-photo-album-plus/js/wppa-ajax-front.js line 561:

    // Download an album
    function wppaAjaxDownloadAlbum( mocc, id ) {
    
    	jQuery.ajax( { 	url: 		wppaAjaxUrl,
    					data: 		'action=wppa' +
    								'&wppa-action=downloadalbum' +
    								'&album-id=' + id,
    					async: 		true,
    					type: 		'GET',
    					timeout: 	60000,

    change the 60000 into 1000000
    this will make the ajax timeout for download album to 1000 seconds

    Thanks Jacob. I renamed .min.js to .min.bak and made the change in wppa-ajax-front.js line 561 to:

    timeout: 240000,

    And set in php5.ini:

    file_uploads = On
    post_max_size = 128M
    upload_max_filesize = 128M
    max_file_uploads = 128
    max_input_time = 600
    max_execution_time = 110
    default_socket_timeout = 120

    Then set WPPA IX A-5 to 100 and killed all the php processes on the server. Download Album still gets a timeout at 60 seconds, so there is another setting in the mix.

    I’ll keep poking around.

    Thanks for the help.
    Ian

    Plugin Author Jacob N. Breetvelt

    (@opajaap)

    I did some research.

    The fact that you get the alertbox saying Only .. out of .. could be added … means that wppa_is_time_up() returns true; i.e. either $wppa_opt[‘wppa_max_execution_time’] is the limit, ( this is setting Table IX-A5 ) or ini_get(‘max_execution_time’) is the limit ( that what is returned for the php setting ‘max_execution_time’. You set the php var ‘max_execution_time’ to 110, glabally as well as local.

    It is worth finding out what ini_get(‘max_execution_time’) returns.

    Near the top of wppa-settings-autosave.php there is a testing area. Add:

    echo 'Max PHP execution time is '.ini_get('max_execution_time');

    to see this value.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Download spin without download and links missing’ is closed to new replies.