Support » Plugin: Seriously Simple Podcasting » Download link not working

  • When I press the download link under the player, it does not download the file. There seems to be nothing wrong with the file because the player plays the uploaded mp3 file. I am new to simply podcasting and maybe I miss something.

    I have updated to the latest version (1.16.1).

Viewing 9 replies - 16 through 24 (of 24 total)
  • Hello Jonathan–
    OK, I was able to download one of your .mp3s.

    Btw we are not hosted on WPEngine. We use a caching plugin created by our host, SiteGround. I don’t know if that is “particularly aggressive,” but the download function used to work on our site, and only the download function does not work. Exactly when it stopped working we don’t know.

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hello Jim, thank you for the feedback.

    It is possible that the caching plugin is causing the problem with the download. Are you able to test this? The simplest way would be to disable the plugin, and then visit the site using something like Chrome’s Incognito mode (so that it grabs a fresh copy of the site) and try a download link.

    If this does resolve the problem, we can isolate it to being linked to the caching plugin. I can then test this out on our own SiteGround test environment and work with SiteGround support so that we can look at how best to resolve this.

    I appreciate your assistance with isolating this issue.

    Regards

    Hello, Jonathan–

    I disabled SG Optimizer, and tested download. Same problem: a 111-kb file with the name of the .mp3 downloads, but it is not a valid file. This does not surprise me, since as I mentioned the plugin was in place all during the time when the download function worked as expected.

    For the same reason, theme incompatibility is unlikely. Then there is of course all the other plug-ins. Before I go through the tedious chore of turning them off and on, do you have any idea of the sort of plug-in that might cause a problem, aside from those for caching?
    –Jim

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi Jim

    The only known issues we’re aware of related to the media files either not playing or downloading are detailed in this help article:

    https://www.seriouslysimplepodcasting.com/doc/podcast-audio-will-not-play-anywhere/

    The file download uses a custom url which serves the actual file, so I can only assume a plugin or some piece of code in a child theme (if you are using one) that hooks into or effects this functionality would be causing this.

    Regards

    Thanks.
    I ruled out cache issues by testing turning them off (SiteOrigin has one that you manage through CPanel.)

    SiteGround told me they do use nginx for some things. When I referred their rep to your request, she responded “I am afraid that it is technically not possible for us to edit the nginx configuration file. The pre-sets are made on all shared servers and cannot be edited.”

    When I tried the .php code bit from GitHub, the download function turned off. Selecting “Download file” opened the media player.

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi Jim, thanks for the update

    Does SiteGround support a staging site? I’d like to rule out a plugin conflict with you first. If you’re in a position to set up a staging site on your hosting account with a copy of your current site, I’d be happy to go through the process of ruling out a plugin or theme conflict.

    If we do rule that out and it is hosting related, we can chat to Siteground and see if we can figure out a work around.

    Thanks, Jonathan. That would be great.

    As it happens I set up a staging site a few months ago for other purposes, and it is still up. It’s at http://uucb.org/dev/

    To keep the size of the staging site low I did not copy all the .mp3s. Links on the staging site point to the real site anyway. For the sake of testing I uploaded one .mp3 to the staging site here: http://uucb.org/dev/?uu_services=summer-awe

    The same issue with downloads occurs on the staging site, so nothing I’ve done since the summer on the real site has caused the problem.

    I assume you will want admin credentials. Let me know where to send them.

    Btw I tried disabling the functions.php file I have in the child theme to see if there might be something there that caused the issue. Same problem, unfortunately.

    –Jim

    Hello again-
    Btw, I had additional contact with SiteGround. They said:

    “The servers is using the NGINX server as a reverse proxy.

    With that said, I am afraid that I couldn’t determent the exact root cause of the issue, as it seems that it’s not related to the server environment, but rather the the Podcast plugin.

    In the provided github, it seems that these rules [he means the rules that a page of yours suggested be added to any nginx server] are security risk for the environment:
    https://github.com/TheCraigHewitt/Seriously-Simple-Podcasting/issues/131

    Mind that on the shared hosting solutions the NGINX configuration cannot be changed as it’s globally defined. Such functionality is only provided on the Dedicated hosting solutions.
    https://www.siteground.com/dedicated-hosting.htm

    I can suggest you to contact the plugin developer and ask them to see if there are any other ways of re-configuring the plugin.”

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi Jim, thanks for the feedback.

    Could I ask you to email me at hello@seriouslysimplepodcasting.com (mark the email for Attention Jonathan) so that you can share the stating environment details with me there.

Viewing 9 replies - 16 through 24 (of 24 total)
  • The topic ‘Download link not working’ is closed to new replies.