Support » Plugin: Seriously Simple Podcasting » Download link not working

  • When I press the download link under the player, it does not download the file. There seems to be nothing wrong with the file because the player plays the uploaded mp3 file. I am new to simply podcasting and maybe I miss something.

    I have updated to the latest version (1.16.1).

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Craig Hewitt

    (@podcastmotor)

    Hi @debeerj,

    Thanks for the message and sorry to hear you’re having some trouble with the download functionality. Could you send over a link to your site or an episode that you’ve got published? I’ll take a look and see what could be going on.

    Also do you have any caching plugins active on your site or server? These don’t typically cause a download failure (more often a playback issue), but just in case it might be worth looking at.

    Craig

    Here is a link to a url where we use Seriously Simple Podcasting for our sermons: http://goodwoodbaptistchurch.co.za/gbc/multimedia-archive/20170514-pm-bless-and-curse-not-romans-1214-17-21/.

    Is there any feedback on this issue?

    Jaco

    I just want to add that I have the same problem as you and the latest 1.16.2 update didn’t help.

    I would like to add that everything else works fine, it’s just the download link under the player. Itunes downloads are fine, playing the file in the player is fine and even you can use the download link if you first do “open in a new window” to use that download link. It’s just a problem with the default player download link.

    Comparing the difference between the download link of the default player with the one that works in “play in new window” shows different links. The working link points to the expected upload folder, but the non-working link points to a non-existent folder of “../podcast-download/4004/xxxx.mp3?ref=download”. I’m not a developer, but I think the issue lies in this link somehow.

    Plugin Author simondowdles

    (@simondowdles)

    Hi debeerj,

    Thanks for following up. PLease note that I clicked on the “Download File” link on this page ( http://goodwoodbaptistchurch.co.za/gbc/multimedia-archive/20170514-pm-bless-and-curse-not-romans-1214-17-21/ ) under the Podcast titled “2017/05/07 PM: Bless, and Curse Not (Romans 12:14; 17-21)”.

    It downloaded perfectly fine for me. If you’re still having problems, please visit this site and send the details so simondowdles [at] gmail.com -> http://supportdetails.com/

    Thank you!
    Simon

    FYI Simon, when I goto that link, the download is 0 bytes. It appears to download, but there is nothing there. I tried both Chrome and IE with the same result.

    I’ll let you work with debeerj though, but I’m hoping you guys find something.

    That is exactly the problem. It appears to download, but it is zero bytes. In chrome a message is displayed on the download that actually says, download failure.

    Is there any feedback on this problem?

    JimGasperini

    (@jimgasperini)

    Has there been any response from the plugin developers to this problem?

    On our site the download link displays normal behavior on a MacBooK
    –in Safari, the usual animation shows a file going to the Downloads folder. The file however is sized 111 Kb and will not open in an media player
    –in Chrome, a tab attaches to the bottom of the screen; in the Downloads folder a temporary downloading file displays a progress meter, which never moves.

    I am pretty sure that the download function used to work. If it didn’t, when I set this up on our site less than two years ago, I would have found some alternative to Seriously Simole Podcasting.

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hello @debeerj and @jimgasperini, thanks for getting in touch with support. @debeerj, my apologies that we have replied so late.

    At the moment we are not aware of any issues with the download option, however I would like to work with you to determine the cause of the problem.

    Could you post your website url here, so that I can see the problem in action? If you do not want to share the url publicly you can email hello@seriouslysimplepodcasting.com with the subject line ‘Attention: Jonathan – Download Problem’ and I will reply there.

    Thanks

    Plugin Author Craig Hewitt

    (@podcastmotor)

    HI @debeerj and @jimgasperini

    Just to add to what Jonathan mentioned if you’re hosted on WPEngine or have more aggressive caching plugins installed/configured you could be running into a redirection issue as described here: https://www.seriouslysimplepodcasting.com/doc/podcast-audio-will-not-play-anywhere/

    We’ve seen resolution with these situations really easily and are actively working with the team at WPEngine to set up a platform wide exception for this behavior so it’s resolved for everyone, out of the box.

    Craig

    Thanks for responding Jonathan.
    The problem we experience can be reviewed at
    http://uucb.org/worship/service-archive/

    Thanks,
    –Jim

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi Jim, thanks for getting back to me. I can see the problem you are experiencing.

    Could I ask you to test out one of the podcasts on this site: https://wphackercast.com/. It is also using Seriously Simple Podcasting.

    If you are able to download a podcast file from that site then there is possibly either a hosting or plugin conflict and I would like to work with you to isolate and resolve the problem.

    Regards

    Hello, Jonathan–
    I tried twice to download the French woman’s episode.

    First I tried in Safari. A new tab appeared, blank except for the URL. Then the machine (MacBook Pro) froze – endlessly spinning beachball. I had to force reboot.

    I switched to Chrome. Another blank tab appeared, and a “something is downloading” animation flashed by. In my downloads folder I could see a file-downloading progress bar, then it disappeared. The machine slowed to a crawl. I tried to scroll down the Downloads folder to see if a file starting with H had downloaded, but could not scroll. I was able to open Activity Monitor, and saw that the wphackercast.com/ page was taking nearly 100% of the CPU. I force quit that page, and the machine gradually returned to normal. At the bottom of the Chrome screen a band informed me that the …03.mp3 file had failed to download due to “network error.”

    I could try again, but this has taken over an hour of my time and I need to turn my attention elsewhere. I will ask a colleague, who first alerted me to the problem, to see if he can download a file from https://wphackercast.com/
    –Jim

    Plugin Author Jonathan Bossenger

    (@psykro)

    Hi Jim

    I’m sorry you were experiencing problems yesterday, it seems there was a network error with my site last night, causing these problems. I was also testing out a new media player, which may have caused some issues.

    I’ve reverted back to the original media player and tested my site this morning and the downloads are working again. Please re test and let me know what happens.

    https://wphackercast.com/

    Regards

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Download link not working’ is closed to new replies.