Support » Plugin: WP License Manager » Download failed forbidden

  • Resolved mahlamusa

    (@mahlamusa)


    Hello there Jarkko, thank you very much for this amaizing plugin, I have followed the tutorial very well but I installed your latest version of the plugin from the wordpress repository.

    The problem is that when I attempt to update a licensed plugin, first I got an update error with a “Not found” kind of error. After the failed update, wordpress says the ‘test’ plugin is updated but it still shows the old verion number

    I didn’t change anything since then and now when I come back to my dashboard I find that there is an update (the one that failed to update) and when I try to update I get the following error:

    Downloading update from http://<site-url>/api/license-manager/v1/get?p=who-hit-the-page-widget&e=webmaster@<domain>.co.za&l=IY%29U8U%2A%23V%236ru%23%29YNS4%23DIt%21…
    
    Download failed. Forbidden

    I don’t know what is wrong, my AWS credentails are ok and I am using a valid email address and license created using the plugin. Please help.

    And I was wondering, what is the progress regarding integration with ecommerce plugins? I am using MarketPress to sell my plugin and I am able to hook into MarketPress order paid hook and generate the license and associate it with the email address used on purchase, I am strugling to get the product id from market press and generate a license for a product in the license manager. For now, I have to hardcode the product_id for the license manager but obviously this will not work once I start selling multiple products on the same website.

    Any pointers and help will be highly appreciated

    https://wordpress.org/plugins/wp-license-manager/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter mahlamusa

    (@mahlamusa)

    Now I get the following when I select all plugins that need updates,
    An error occurred while updating <plugin name>: Download failed. Service Unavailable
    This error is for the plugin managed by the license manager

    Plugin Author Jarkko Laine

    (@jarkkolaine)

    Hi mahlamusa,

    Sorry for the slow reply! I’m looking into this now, but couldn’t yet reproduce the problem on my test server (for me, everything is working at the moment). If you are still working on this and have any additional info you think might be useful, that would be great!

    The first error sounds like a problem with the AWS configuration. If you have your test plugin in a directory inside the AWS bucket, it’s important that the directory name goes in the filename field in Products rather than the bucket field. Mixing this up caused a similar error for me a little while ago.

    Regarding the second error, I got the same error when I tried running the update on the same WordPress install that also works as the license server. When using two separate WordPress instances, the error went away. Could this be the case for you too?

    As for the e-commerce integrations, I’m looking into that now. I’m not sure about schedule yet, though. A lot depends on my other projects…

    Thanks!

    Jarkko

    Thread Starter mahlamusa

    (@mahlamusa)

    Thanks a lot. I have moved the licence manager to a subdomain of the site using the plugin that I am trying to update using the licence manager and I have noticed that I have missed the step to attach access Policy to grant the user access to my bucket, I have done that and now it works.

    Perfect

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Download failed forbidden’ is closed to new replies.