Support » Plugin: Memphis Documents Library » Download Error:Warning: array_multisort():

  • We’re getting this error when backend uploading or on the front end, trying to download documents:
    Warning: array_multisort(): Array sizes are inconsistent in /home/bellmawr/public_html/wp-content/plugins/memphis-documents-library/includes/mdocs-functions.php on line 574

    Disabled theme, used 2019. Disabled all Plugins. Checked System Compatibility – all good.
    Deleted a test doc, added it back in.

    Nothing is working. When you download the docs, its all special characters and gibberish. The files are fine on the server, downloaded and checked.

    We noticed the issue because we were researching this error: mDocs Error: Memphis has terminated due to a faulty nonce check. This check is needed to deter Cross-site scripting security vulnerabilities Not sure if it’s related.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • For everyone else seeing this, we seemed to have fixed it by rolling back the PHP version to 7.0.33

    Unfortunately that didn’t work for us. Upgraded from an older version, and with every download we get the same error:
    Warning: array_multisort(): Array sizes are inconsistent in /home/clientname/webapps/clientsite/wp-content/plugins/memphis-documents-library/includes/mdocs-functions.php on line 574

    After I saw your post I tried to change from php5.6 to 7.4, 7.3, 7.2, 7.1, and finally 7.0. Nothing. Have to restore from a previous backup and remember to never update this plugin…

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Download Error:Warning: array_multisort():’ is closed to new replies.