WordPress.org

Support

Support » Plugins and Hacks » WooCommerce » [Resolved] Downgrade Woocommerce without losing data

[Resolved] Downgrade Woocommerce without losing data

Viewing 7 replies - 1 through 7 (of 7 total)
  • use your backup.
    the backup the programme asked you to make before updating

    or are you one of those real guys?
    Real guys do not take backup – they cry!

    Haha sure I thought I made a backup but the backup went wrong 🙁

    But I just read downgrading isn’t all that when there isn’t a backup related to 2.0.20….

    You won’t lose products when you overwrite your 2.1.* files with 2.0.20, but you need to restore your pages (that have been changed into endpoints in 2.1).

    As long as you don’t delete the WooCommerce plugin via the administration panel (so don’t click the delete link there, you can deactivate though), your data will be safe.

    Information about adding the pages back can be found in your (2.0.20) administration panel via WooCommerce > Settings > Pages (tab). It will list there what pages are missing, also shown on the System Status page.

    Finally, this shows the importance of having proper backups. Please make sure you at least make a backup (and test it!) before you try to revert to 2.1.1.

    my products page and shopping cart icons are all messed up now. How do i downgrade back to 2.1

    I would appreciate a details steps

    thank you

    there is 30 template pages out of date with new upgrade. how to upgrade all?

    If you have purchased a theme, contact your theme developer. They have probably (at least, I hope that’s why they bundled all template files…) made modifications to the template files, therefore there is no way to automatically update the template files without losing the things your theme did to them.

    If it’s a custom made theme by yourself, you should match the template files bundled in the plugin to the template files bundled in your theme. There will be differences and these need to be updated in your theme’s files.

    I’ve just updated woocommerce plugin to 2.1.6 version and cart page displays the code:
    Warning: call_user_func(WC_Shortcode_Cart::output) [function.call-user-func]: First argument is expected to be a valid callback in …./wp-content/plugins/woocommerce/includes/class-wc-shortcodes.php on line 70

    The page does not display anything else, just this code.

    Another problem is that My Account page does not work properly. Cannot edit Billing and Shipping addresses, neither the ‘change the password’ option works.
    I’ve tried to deactivate other plugins and then active one by one, but it did not make any change.

    Any help would be appreciated.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Downgrade Woocommerce without losing data’ is closed to new replies.
Skip to toolbar