WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Downgrade from 3.5 to 3.4.2

[Resolved] Downgrade from 3.5 to 3.4.2

  • Hi!
    I’ve got a big problem! How to downgrade from 3.5 to 3.4.2?
    All the plugin I have installed don’t work anymore!!
    I was near finishing my work for a client deadline!!

    Please help!

Viewing 14 replies - 1 through 14 (of 14 total)
  • I had to downgrade to 3.4.2 on a couple of sites. The admin menus ceased to function properly and the widget panel drop-downs broke as well. Reverting to 3.4.2 fixed it. Not sure what the issue was. It happened on two sites with completely different themes and plugin groups. Four other sites I upgraded worked fine.

    How did you downgrade? What did you do?
    I have languages plugin and background gallery not working 🙁

    I’m afraid to loose some contents..

    WordPress just crippled everything… New posts do not allow the main text area to function (visual or html, no difference). Dashboard fails to load properly. Lighbox broken. All sorts of fundamental changes.

    Never have I regretted updating to the latest version so badly. Someone please post a nice guide on reverting!

    Used this:
    http://etuts.org/manually-downgrade-wordpress/

    It worked fine for me.. downgraded in 5 minutes 🙂

    Thank you. Worked perfectly!

    Upgrading to 3.5 completely screwed up the WYSIWYG editor.
    Downgraded using the above tips, worked perfect. Thanks everyone. 🙂

    Thanks! for this post. 3.5 has broken the theme I use also.

    Hopefully this will all get resolved soon. Downgrading did the trick for me. And it’s unfortunate because 3.5RC3 was working fine for me.

    @rishi, mdesouza, eclipseprime, cdechery – Did you guys use Bulletproof security? That seemed to be one of the major plugins wrecking havoc. I was in the same boat, reverted and will be waiting for ’20 plugins/themes’ need updating before I upgrade wordpress again.

    Thanks to this post guys, Everything worked well. I have tried deactivating all the plugins on the site and it remains the same, at first I thought it was not supported by the theme I used but after reading other posts I found that it might also affected by the security plugin installed on specific sites. Thanks Again @nur-art TS. 🙂 Worked like a charm.

    I tried the downgrade and got errors

    Warning: require(/home/postform/public_html/wp-includes/load.php) [function.require]: failed to open stream: No such file or directory in /home/postform/public_html/wp-settings.php on line 21

    Fatal error: require() [function.require]: Failed opening required ‘/home/postform/public_html/wp-includes/load.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/postform/public_html/wp-settings.php on line 21

    Did it, everything works fine!

    esmi

    @esmi

    Forum Moderator

    Do not attempt to downgrade WordPress unless you can also restore a pre-upgrade database backup. The database was changed for WordPress 3.5 and a 3.5 database should not be used with 3.4 core files.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] Downgrade from 3.5 to 3.4.2’ is closed to new replies.