Support » Networking WordPress » Downgrade a superadmin

  • Resolved Prometheus Fire


    I recently upgraded one of my testing user accounts to give it superadmin priveleges. I did it to test for a bug, but now I can’t undo it. The checkbox on the user profile doesn’t appear. (I read in the trac somewhere that the devs removed it). I looked into the database usermeta tables hoping I could figure it out how to change it in there but can’t see anything obvious.

    So, before I break something important, how do I downgrade a superadmin back to a regular user account?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    Go to /wp-admin/network/users.php

    Click on ‘edit’ for the user.

    There’s no checkbox there?

    Are you logged in as the user?

    Is their email the same as the network email in /wp-admin/network/settings.php ?

    Prometheus Fire


    Yeah, this was a knucklehead moment. I was doing it wrong, I was still logged in as that test user. I’m so used to seeing the network admin screens in the primary account that I didn’t notice wasn’t logged in using the primary account.

    All was okay when I logged back in under the primary superadmin.

    I was doing it wrong! (and to think I was going to start changing stuff in the database…that wouldn’t have turned out well…)

    One must be logged in with the primary superadmin account (the one represented in admin_email in the database) to control superadmin permissions.

    Thanks, this is resolved!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Downgrade a superadmin’ is closed to new replies.