Support » Plugin: Yoast SEO » Double post titles on Google again

Viewing 4 replies - 1 through 4 (of 4 total)
  • Just to add a note here. I am also using the Video SEO plugin… so any posts that have video are not duplicating, but the others are.

    This is the Yoast SEO header in my index page. You can see the duplicates:

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.4.4 - -->
    <meta name="description" content="Personal blog of Julie Arnold."/>
    <link rel="canonical" href="" />
    <link rel="next" href="" />
    <link rel="author" href=""/>
    <meta property='og:locale' content='en_US'/>
    <meta property='og:title' content='Idle Journal - A Diary of Living, Livelihood, and Finding a Calling'/>
    <meta property='og:description' content='Personal blog of Julie Arnold.'/>
    <meta property='og:url' content=''/>
    <meta property='og:site_name' content='Idle Journal'/>
    <meta property='og:type' content='website'/>
    <!-- / Yoast WordPress SEO plugin. -->

    I also found this in my header.php but I’m not really sure what it’s doing.

    <title><?php wp_title(''); ?><?php if( wp_title('', false) ) { echo ' &ndash; '; } ?> <?php bloginfo('name'); ?> &ndash; <?php bloginfo('description'); ?></title>

    Other threads with same issue: <– this one reportedly has a fix?

    I commented out the above <title> tags but I’m still getting duplicates on G+.

    It turns out Jetpack conflicts with WordPress SEO on this one. I disabled the og tags in SEO >> Social and now I only see the <!– Jetpack Open Graph Tags –> info. It also posts to Google Plus with only one title & description. If you want the custom description from WP SEO try following Yoast’s guide:

    A common problem that’s been around for awhile since Jetpack won’t change it.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Double post titles on Google again’ is closed to new replies.