Support » Plugin: Loco Translate » Double .po language files

  • Hi!

    For many years I use Loco translation without any issue. But for no logical reason I have an issue. In my WP install I also use WooCommerce and Tribe Events. After each WC or Tribe update the original language files are placed back and set as main PO file. The PO file with custom translations is saved in the “custom” language folder. The PO file in the “system” folder is the original PO file, but now I can’t seem to select the custom file. Any suggestions?

    Here’s a clip with my situation explained:

    Thanks
    David

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Tim W

    (@timwhitlock)

    but now I can’t seem to select the custom file

    The custom file should override the system file. If that’s not happening, your screen recording doesn’t show it. It just shows two PO files, which is normal.

    Please provide steps to reproduce the system file taking priority over the custom file.

    Thread Starter dhager

    (@dhager)

    Hi Tim,

    Thanks for your swift reply. I recorded an additional video to explain that the custom PO file doesn’t get prioritized over the system file.

    Thanks!
    David

    Plugin Author Tim W

    (@timwhitlock)

    How do I install this Event Tickets plugin? To identify if there is a bug in Loco Translate I need to reproduce your issue, not just watch a video of it.

    It strikes me that this is a display issue – possibly the plugin is not loading translation files in a standard way compatible with Loco Translate’s custom loading feature – See this FAQ.

    Thread Starter dhager

    (@dhager)

    Thanks Tim. I will have a look and maybe this loco-loader.php will work.

    Here the plugin I use : https://theeventscalendar.com/

    Plugin Author Tim W

    (@timwhitlock)

    I don’t see any links to download your plugin for free. If it’s a commercial plugin there is no help here for debugging it.

    Thread Starter dhager

    (@dhager)

    Hi Tim,

    Yes, sorry here is the plugin link https://wordpress.org/plugins/event-tickets/
    and they also promote Loco: https://theeventscalendar.com/knowledgebase/k/managing-translations-with-loco-translate/

    So the issue is clear to me now. The custom stored file is not prioritized over the system file. The reason why is unclear to me as I don’t see any alternative settings or options to make this selection. Right?

    Thanks again!
    David

    Plugin Author Tim W

    (@timwhitlock)

    This plugin suffers from the early loading problem described in the FAQ I gave earlier.

    It doesn’t bother to wait for all plugins to initialise before it loads its text domain. Hence Loco Translate cannot do its job.

    The reason why is unclear to me as I don’t see any alternative settings or options to make this selection. Right?

    Correct. There is no option. It will either work if the plugin loads text domains properly, or it won’t. In this case, it won’t.

    Plugin Author Tim W

    (@timwhitlock)

    I will have a look and maybe this loco-loader.php will work.

    You can try it, but I can’t provide support if it doesn’t work. Or if it causes other issues.

    I would recommend you ask the authors of your plugin to fix their code so other plugins can listen on WordPress localisation hooks. If they publicly recommend Loco Translate, they might be keen to support it more fully.

    Thread Starter dhager

    (@dhager)

    Okay thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Double .po language files’ is closed to new replies.