Support » Plugin: Add-on WooCommerce - MailPoet 3 » Double Opt-In does not work properly

  • Hello,

    i have two problems using the plugin:

    1. Although I have activated Double-Optin, I do not receive an e-mail confirming the newsletter registration.

    2. After submitting the order the subscriber is already in the status “checked”. He is not assigned to any list. (I have selected a list in the settings)

    When I sign up directly through a mailpoet form, I receive the email for the Double-Optin and the status is correct.

    What can this be?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Hello,

    Thank you for reporting. We are now looking into that issue.

    Thanks.

    Did you select correct list from WooCommerce > Settings > MailPoet > Available Lists? It’s necessary otherwise you will face those issues.

    Also please keep your plugins up-to-date and update the WooCommerce database from dashboard (only when WooCommerce prompts)

    Thanks

    Thread Starter heikof

    (@heikof)

    Hello,

    Thanks for the very fast feedback.

    I have two lists under “WooCommerce> Settings> MailPoet> Available Lists”. I chose the right list there – without success.
    For the test, I have now set the hook on both lists. This does not solve the problem.

    All my versions are up to date.

    Hello,

    I have tested the plugin in our two WordPress installations. The plugin is working fine and didn’t face any issue that you mentioned above. Did you see any error in php/debug log?

    Thanks

    Thread Starter heikof

    (@heikof)

    Hello,

    no php errorlogs are generated. I’ve also disabled all other Woocommerce addons for testing (like Booster for Woocommerce, etc.)

    No e-mail will be sent for the Double-OptIn.

    Can I give you the wordpress admin data so that you can check in the system if a setting is wrong?

    Hello,

    I faced the exact similar issue ONLY when I don’t select the available list from “WooCommerce> Settings> MailPoet> Available Lists”.

    I have added some screenshots of our plugin configurations:
    WooCommerce> Settings> MailPoet>:
    https://prnt.sc/oznc7h

    WooCommerce> Settings> MailPoet> Available Lists:
    http://prntscr.com/ozn5iw

    Thanks

    Thread Starter heikof

    (@heikof)

    Then I have to look elsewhere for the problem. My settings in the plugin are correct.

    Thanks for your help.

    https://prntscr.com/oznsx4

    https://prntscr.com/oznsz9

    Hello, there are something I need to know.

    1. Do you use MailPoet Sending services for sending email?
    2. Do you have any other MailPoet plugin installed besides MailPoet 3?

    Thanks

    Thread Starter heikof

    (@heikof)

    Hello,

    1. No, i use my own host. When I sign up directly through a mailpoet form, I receive the email for the Double-Optin and the status is correct.

    2. No

    Unfortunately, I have the same problem. Are there any news on the subject? Thanks

    Hello,

    Is there any error log in your server?

    Thanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Double Opt-In does not work properly’ is closed to new replies.