Support » Plugin: Fast Velocity Minify » Double load of jquery

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Raul Peixoto


    Looking at your site, it’s not being loaded twice.

    What I see is:

    <script type="cddf9537f0c7cce480412170-text/javascript" src=''>


    <link rel="preload" href="/wp-includes/js/jquery/jquery.js?ver=1.12.4" as="script">

    But this is unrelated to FVM, probably some code on your theme or some dependency on some plugin. I’m almost sure that if you delete FVM these are still there.

    The first one is a script inclusion, the second is a preload.

    FVM is not doing that.

    Hi Paul, thx for the quick answer.

    I’ve looked deeper into this: The double load of jquery.js only occurs, when I active you plugin AND the cloudflare plugin AND activate CLOUDFLARE_HTTP2_SERVER_PUSH_ACTIVE in wp_config. So I deactivated it and it works fine again.


    Plugin Author Raul Peixoto


    Thanks for the info on cloudflare.

    You could use the preload option in FVM for really important stuff, but it’s not quite the server push you’re looking for.

    I’m considering adding server push to the plugin, but I’ve seen “error 500” on a few hosting providers after trying some other plugins that had that functionality… so it’s not a big priority for me.

    Nevertheless, it’s on the roadmap 🙂

    Thanks again.

    It would be a great feature to have http/2 server push within the plugin (this is, where such an option would make sense). I would like to test it with CloudFlare. I think the file which should be pushed should be named manually, because it does most times not make sense to push all files.

    I have another feature wish: in the present version of the plugin, nearly all js/css files are merged in one or two (header/footer) files. This is for the first page request of a site the efficient way. But for the second and all following page requests of the same site, often files are transmitted again and again, which could be cached from the browser if there where not merged. It would make sense to have an option like: don’t merge the top 3 files sitze larged size when there are needed on other pages. Mostliy this should be in case like font awesome and other js files like jquery.charts which are really big and loaded all the time by some themes (even if you don’t need them).
    At the moment you can put these file on the ignore list, but this must be done manually and I think nobody does it 🙂


    Plugin Author Raul Peixoto


    I’m not sure I follow.

    Why would you don’t want to merge certain css files that are needed on certain pages?

    FVM finds a set of used css or js files and creates a group of files, merged into one static file.
    Most of the time, the same set of css or js files can be reused, so for example, a fvm generated css file on a post, can probably be reused on all other posts too (and that’s what happens).

    That way, if a user visits 2 different posts, the second request will always be faster, since the css or js file is already cached on it’s browser.

    If I were to exclude certain css files, I would be increasing the http requests (which is the opposite of what FVM intends to do) and forcing the plugin to merge a new set of files, thus invalidating your existing browser cache.

    I don’t see any benefit of excluding font-awesome from the css file, if it’s being loaded on all pages by some other plugin. Being merged is the way to go, since it would avoid doing 2 requests.

    And if for some reason font-awesome is not used and you don’t want them there… then you can dequeue it manually on your theme.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Double load of jquery’ is closed to new replies.