Support » Theme: Twenty Seventeen » Double Homepage section

  • Resolved Sheriziya

    (@sheriziya)


    Well, I fixed the “No Theme options” problem on the homepage, but now I suddenly have one page twice in the homepage, where one can’t be removed. The Homepage which I selected as the first section, is also showing up above that first section without any option to edit or remove it. As you can see here, there’s simply no option.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Thread Starter Sheriziya

    (@sheriziya)

    Just to clarify (in a reply, since I can’t edit my original post anymore). At the moment I have selected the About page as first section. The Home page isn’t selected anywhere.
    As you can see in this picture, the Home page section is still showing up, while the About section is showing up beneath that.

    How did this happen and how can I fix this? Does this have anything to do with the fact that I changed themes (2017 -> 2015 -> 2017) to see if that would solve my other problem of the Theme options not being available in the customizer when I was at the mainpage (Changing the themes didn’t help, btw, but deactivating and deleting the plugin WpBooklist did work).

    @anevins, do you happen to know how I can fix this issue?

    Thanks for the help!

    • This reply was modified 4 years, 9 months ago by Sheriziya.
    Thread Starter Sheriziya

    (@sheriziya)

    @anevins or anyone else, this problem still hasn’t been fixed.

    How can I fix this problem?

    Andrew Nevins

    (@anevins)

    WCLDN 2018 Contributor | Volunteer support

    @sheriziya, Please stop pinging me. If I knew the answer I would post it, likewise is the case for other people too.

    Thread Starter Sheriziya

    (@sheriziya)

    Sorry Andrew. Well, I hope someone knows the answer.

    What have you chosen as your home page option under
    Appearance > Customize > Home Page Setting — Homepage ?

    I have to assume you have chosen the static page option.

    Under
    Appearance > Customize > Theme Options you have chosen to use a further section on the home page, in this instance “About”

    If you cancel this, you should only have the page you have designated the homepage showing.

    As to the failure to edit the section in the Customizer, that makes sense since the customizer is only taking the published pages to place them on the homepage. You should be able to edit the pages themselves as you would normally.

    That is what it looks like to me from this distance.

    Regards,
    Stilman

    Thread Starter Sheriziya

    (@sheriziya)

    I have indeed set up a static page as the homepage, which was intended. The about page was supposed to show as an extra section on the main page, so that was also intended.

    So…. I checked my other sites, which both use 2017 as well. Somehow in one of them the customizer said static page and then homepage as section while only showing the homepage once. Apparently at THAT site something wasn’t displaying in the customizer as it should, which I hadn’t noticed before.

    Anyway, to make a long story short, as it turns out the sections and the home page are indeed acting as they should, like you said. I’ve fixed that now quickly on my other site as well (no idea what was going on there, especially since I didn’t change a thing there in over months!).

    So…. It’s fixed in the other site and here it never was a problem. I just wasn;t aware of the difference.

    Thanks, @stilman-davis, for your help.

    Regards,
    Sheriziya

    Thanks Stilman for your answer on this. I had the same problem and it can be quite vexing. I’ve looked at many answers online and yours did it. I just needs a careful reading. Thanks again!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Double Homepage section’ is closed to new replies.