Support » Fixing WordPress » Double border to #page Twenty Eleven

  • When I add a double border around #page, the links in my widgets don’t work. I can’t figure out why this is happening. I’ve also looked for other ways to add a double border, but am having no luck.

    Website: theblendcorvallis.com/

    Below is the code I’m using. I’ve narrowed the problem down to: content:””;

    Does anyone know why that would disable widget links and how I can solve this?

    /* border around page*/
    #page{
    margin:0 auto;
    position:relative; /*important!*/
    border:5px solid #008300;
    background: #fff;
    padding:30px;
    border-radius: 10px;
    }

    #page:before {
    content:””;
    position: absolute;
    /*set margins in other words its positioning our added pseudo content*/
    top:2px;
    bottom:2px;
    left:2px;
    right:2px;
    border:5px solid #c56c8a;
    border-radius: 8px;
    }

    Thank you

Viewing 2 replies - 1 through 2 (of 2 total)
  • I am not 100% sure about the problem, but I suppose that you’re positioning the content before #page above the footer.
    Anyway, setting the position of the footer to relative seems to solve your problem:

    #colophon {
        position: relative;
    }

    Thank you so much!! I really appreciate your help!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Double border to #page Twenty Eleven’ is closed to new replies.