Support » Plugin: WPS Hide Login » Dont’t work with TranslatePress Subdirectory functionality

  • Resolved znac

    (@znac)


    Hello,

    I’m using TranslatePress with the Subdir Functionality.

    My input www.mysite.com/login becomes www.mysite.com/de/login. Then I am redirected to the 404 page so I can no longer log in.

    Also if I write following in the settings www.mysite.com/de/login it does not work.
    Because after saving it changes to www.mysite.com/delogin and this becomes www.mysite.com/de/delogin.

    How can I get your plugin work with TranslatePress and subdirectories?

    • This topic was modified 2 months, 4 weeks ago by znac.
    • This topic was modified 2 months, 4 weeks ago by znac.
    • This topic was modified 2 months, 4 weeks ago by znac.
Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support MaximeWPS

    (@seinomedia)

    Hello,

    Thanks for using WPS Hide Login.

    You can solve it by changing the sub-directory setting in TranslatePress.

    You can contact TranslatePress team for more informations about this.

    Thread Starter znac

    (@znac)

    @seinomedia,

    thank you for your reply. Did I understand you correctly that this problem cannot be solved in this way?

    There is either a workaround by disabling TranslatePress subdirectories
    or asking the TranslatePress team for a solution.

    Thanks

    Hi,

    I happened to have the same problem as you at the same time…
    I found that in Translatepress you can exlude paths for translation.
    If you go to the advanced menu in Translatepress, you can exclude your new path.
    “Do not translate certain paths” section.

    • This reply was modified 2 months, 3 weeks ago by gabriel85.
    Thread Starter znac

    (@znac)

    @gabriel85, first of all, thanks for your tip, but I think I’m doing something wrong, because it doesn’t work.

    Which entries did you make?

    Thread Starter znac

    (@znac)

    Thanks to everyone who took care of my problem. So that others can benefit here is the solution to the problem:

    WordPress Version: 5.9.3
    WPS Hide Login Version: 1.9.4
    TranslatePress Version: 2.2.7

    WordPress Settings: Permalink Settings > Post name
    WPS Hide Login: Login url > myLogin
    TranslatePress: General: Native language name > Yes
    TranslatePress: General: Use a subdirectory for the default language > Yes
    TranslatePress: General: Force language in custom links > Yes
    TranslatePress: Advanced: Do not translate certain paths: Exclude Paths From Translation > /myLogin/

    Kind regards

    • This reply was modified 2 months, 3 weeks ago by znac.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.