Support » Plugin: Relevanssi - A Better Search » Don’t work with Polylang

  • Resolved rolandassisla

    (@rolandassisla)


    Hi

    Polylang completely breaks Relevance’s work.
    When Polylang is deactivated, your plugin works very well.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Mikko Saari

    (@msaari)

    Please elaborate: how exactly does it break? Does toggling the Polylang switch in Relevanssi settings help?

    Relevanssi is compatible with Polylang and at least in some cases, compatibility issues can be resolved with careful configuration of Polylang.

    Thread Starter rolandassisla

    (@rolandassisla)

    Navigation Search
    When Polylang is activated: Navigation Search finds nothing.
    When Polylang is deactivated: Navigation Search search and finds everything.

    Search Widget
    When Polylang is activated: Search Widget is working. But I don’t use it. I need only Navigation Search.

    When checked “Use Relevanssi for admin searches” no effect: Search Widget Search search and finds everything.

    Search in the admin interface works in all cases: when “Use Relevanssi for admin searches” unchecked or checked, does not matter.

    Plugin Author Mikko Saari

    (@msaari)

    What’s that Navigation Search? Some kind of AJAX search? The search widget search is Relevanssi, but if the navigation search is some kind of AJAX search, that may not be Relevanssi in the first place.

    Thread Starter rolandassisla

    (@rolandassisla)

    My Theme (Generatepress) shows WordPress search in the theme primary navigation menu search. After activating a Relevance, wordpress search in the theme navigation search is replaced by Relevance search and everything works fine.
    Stops working when Polylang is activated.

    ———————————

    I wrote an answer and then
    updated plugin to the latest version (4.3.4) and looks like search in the primary navigation menu works again.

    ————————————–
    Thank you,
    for a great plugin

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Don’t work with Polylang’ is closed to new replies.