Support » Plugin: Automatic Featured Images from Videos » Don’t work it

  • marcorroma

    (@marcorroma)


    Hi, it seems that since I changed the theme my plugin is not working properly.
    the site is corriereromagna.it
    Is it a problem with the theme or with the WordPress version? I have version 5.2.4.
    Can you help me?
    Thanks

Viewing 14 replies - 1 through 14 (of 14 total)
  • marcorroma

    (@marcorroma)

    I noticed now that the photo is captured and imported into the library, but it is not automatically set as a featured image.

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    the plugin should be theme agnostic in terms of importing and being marked as the featured image in the database. However, we can’t control how or even if the theme shows a featured image on the frontend.

    When you’re checking and saying it’s not being set as the featured image, are you confirming that through the post editor screen? Or by checking the frontend in the archive or single post view?

    marcorroma

    (@marcorroma)

    Both.

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    If you know where to find them, are there any errors in the error log that look like they’re related?

    If it’s not showing as a featured image in the editor screen, then it won’t on the frontend.

    The question ends up now being about why it failed to make the association, especially if the media is being uploaded to the media library as expected. However, I don’t have a set list of things to check based on previous support requests.

    marcorroma

    (@marcorroma)

    No, I can’t see the error log.

    Question: currently youtube videos can be incorporated by simply pasting the link in a “paragraph” block (without having to add a yuotube block). Is it possible that this could cause problems for your plugin?
    Or can it be a permission problem?

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    No, the type of block, from what I’ve seen, shouldn’t be playing any part in things failing there. Plus, if it’s in your library, it was found, parsed, and imported.

    Best I have is this from our plugin:

    // Bail if unable to sideload (happens if the URL or post ID is invalid, or if the URL 404s).
    if ( is_wp_error( $attachment_id ) ) {
    	return;
    }
    
    // Woot! We got an image, so set it as the post thumbnail.
    set_post_thumbnail( $post_id, $attachment_id );
    

    Though it doesn’t completely make sense if you have media.

    marcorroma

    (@marcorroma)

    I insert it in functions.php of my theme?

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    No, that’s the code from our plugin that is meant to set the featured image. The only way I can see that it would get stopped from succeeding. The question would be why an error is occurring, but I don’t have any way to confirm or see why it’s happening.

    marcorroma

    (@marcorroma)

    The only way is to have my premium theme.
    And this:
    https://nb-default.wpthms.com/custom-homepage-8/

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Unless we can get some debugging information provided, I’m not able to provide much help, as it could be a case of any of many issues. Sadly, there’s nothing that I could say “it’s this issue, you need to do this to correct it” for.

    marcorroma

    (@marcorroma)

    Ok.
    But how can I try to fix the problem? Or provide you with the data to fix the problem?

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    The most useful thing would be error logs, whether it be you tracking them down yourself inside your hosting panel, or talking to your hosting support and have them help locate that information. With that, we could see if anything stands out there as a contributing factor.

    It’s definitely possible, but not guaranteed, that something outside of our plugin itself is hindering things.

    If push comes to shove, would you be willing to potentially grant us temporary administrator access to the site so we can see things firsthand?

    marcorroma

    (@marcorroma)

    Hi, I’m willing to give you the name and password of a user as an administrator.
    Where should I send it?

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    For that part, please reach out to us via https://pluginize.com/contact/ with a technical support request and we can get something going from there.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.