Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Asad

    (@artisticasad)

    Hi there,

    Sorry for the trouble. I will try to answer your questions one by one.

    1. Its quite possible that your theme css conflicting ours or the the miss managing of the points mentioned below causing this issue.
    We have tested on the fresh WordPress installation and everything worked fine.

    2. The ‘set size: thumbnail’ gets value of default gallery image thumbnail size which is 150×150. If you see its not visible then probably the size is altered in the theme itself.

    3. post-thumbnail option works if post-thumbnails is enabled in your current theme and the values set using this method:

    set_post_thumbnail_size( 50, 50 );
    

    50 pixels wide by 50 pixels tall

    You can see large thumbnails because the size set by the theme is large itself, and you can only overwrite it in your theme files.

    We also checked the link you provided and found Related Posts are disabled.

    • This reply was modified 4 months, 1 week ago by  Asad.

    Ive enabled your plugin now. Please see what causes the problem.

    Plugin Support Asad

    (@artisticasad)

    It looks like you have selected ‘Custom Field’ to Select thumbnails source in setting of Related Posts > Thumbnails, don’t use this option unless you are using custom fields for thumbnail images source.
    Select the option to thumbnails. By default the size of thumbnails should be 150×150 unless its modified in theme as I mentioned in detail in my previous comment.

    No. Source is “post thumbnails” and size is “thumbnail”

    Ok i tested more and here are my results:

    1. I set default theme (twentysix?)
    2. I disabled fast velocity minify

    This don’t help at all

    3. I changed thumbnail source to custom

    It changed this
    https://imgur.com/BM39pjU

    To that
    https://i.imgur.com/oZeqWOS.png

    First image from the post is not visible here as you see

    Maybe this helps?

      public static function post_first_image() {
    1296	     global $post;
    1297	     $first_img = '';
    1298	     if ($post == NULL)
    1299	       return false;
    1300	     else {
    1301	       $output = preg_match_all('/<img.*?src=[\'"](.*?)[\'"].*?>/i', $post->post_content, $matches);
    1302	       if (isset($matches[1][0])) {
    1303	         // Exclude base64 images; meta tags require full URLs
    1304	         if (strpos($matches[1][0], 'data:') === false) {
    1305	             $first_img = $matches[1][0];
    1306	         }
    1307	       } else {
    1308	         return false;
    1309	       }
    1310	       return $first_img;
    1311	     }
    1312	   }

    4. ive enabled developer mode

    • This reply was modified 4 months, 1 week ago by  matrixpoland.
    • This reply was modified 4 months, 1 week ago by  matrixpoland.
    Plugin Support Asad

    (@artisticasad)

    The above code does’t work with custom thumbnail source option.
    We might need to dig deep into this issue, please contact us here: https://wpbrigade.com/contact/

    Also turn the Developer Mode option from Related Posts settings.

    Thank You.

    matrixpoland

    (@matrixpoland)

    Ok i sent e-mail.

    Developer mode is enabled.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.