WordPress.org

Forums

[resolved] Don't want to override my basic site. (22 posts)

  1. Arsov
    Member
    Posted 2 years ago #

    Hi,
    I'm pretty new to WordPress world, learned some basics, made one test page and than lost myself in a Network setup.

    I made my homepage with Xara Web Designer and now I would like to do few additional pages for other ppl with a WordPress. Xara WD does not support CMS, so I thought WordPress would be the best solution. I tried to install network inside the WordPress but noticed that WP intend to take control over my whole site overriding everything that it is already there.

    How can I make additional independent pages with WP on my server without overriding my home page. Is there any relatively simply way to do that?

    I'm on a iPage.

    Thanks in advance for your answer
    Alex

  2. tomontoast
    Member
    Posted 2 years ago #

    I would suggest creating a sub-folder from your existing site and installing your wordpress site in that location so there are no clashes between the two. There are ways of setting up wordpress so the default homepage isn't wordpress, get back to me if this is what you would prefer to do.

  3. Arsov
    Member
    Posted 2 years ago #

    Thanks,
    I'm not sure how to install WordPress in subdirectory and also, if I did that, would it be possible to set up network for WordPress in that subdirectory without messing with my default homepage?

    My main goal is to make many different pages with WordPress that would be accessible through the various domain names pointed directly to the desired page( a subdirectory for every page.. ), leaving my default homepage as it is.

  4. tomontoast
    Member
    Posted 2 years ago #

  5. Arsov
    Member
    Posted 2 years ago #

    Thanks :)

  6. Arsov
    Member
    Posted 2 years ago #

    I've read all the posts on that link.My WP is already in WordPress subdirectory. My main problem is that it is working as long as I have just one WP page, but if I try to make network through the Tools Network settings it notify me that WP will override default settings adding itself as a default page. Is there a way to avoid that and how can I do that?

    Thanks in advance

  7. tomontoast
    Member
    Posted 2 years ago #

    Ok say your html page is called index.html you need to edit your .htaccess file to make this the default page which loads over wordpress.

    Add DirectoryIndex index.html to the .htaccess file

  8. Arsov
    Member
    Posted 2 years ago #

    After installing network or even before?

    btw my htaccess file is totally empty. what exactly should I write in it?

  9. tomontoast
    Member
    Posted 2 years ago #

    Assuming your file is whatever.html just write
    DirectoryIndex whatever.html

  10. Arsov
    Member
    Posted 2 years ago #

    and maybe; I even think that this could be done during the network installation, as there are some note what network installation will change and what the user should change, but I'm not sure how to do that and what should I change there.

  11. Arsov
    Member
    Posted 2 years ago #

    I did that but now when I try to use WP i got "Directory has no index html file" message.

    Please help.

  12. tomontoast
    Member
    Posted 2 years ago #

    Explain exactly what you have done and perhaps give links and then I can try to help.

  13. Arsov
    Member
    Posted 2 years ago #

    My homepage is http://www.arsov.net
    My wordpress sites should be
    http://www.arsov.net/Wordpress/ ( no index file ) and
    http://www.arsov.net/Wordpress/theesound/ ( showing just a fonts without any picture)

    I made all the changes that WordPress Network setup had suggested. Wrote and replaced the code in wp-config.php, added the code that WP suggested also in htaccess inside the WordPress directory. ( I'm a bit confused as there are two htaccess files. One is in the root directory and second inside the WordPress directory.) Also in a wp-content directory I made subdirectory called blogs.dir

    Before all that I also added in a root htaccess file the line you suggested: DirectoryIndex Index.htm

  14. tomontoast
    Member
    Posted 2 years ago #

    Ok I see what you are trying to do. Something has gone wrong with your settings. Delete your site and try setting it up again. Since the site is in the wordpress directory you don't need a .htaccess file in the root. Ignore what I said previously about .htaccess files as this only applies when wordpress is in the same directory as the rest of your site.

  15. Arsov
    Member
    Posted 2 years ago #

    I deleted that line from root hcaccess file, now the primary site that I done it in http://www.arsov.net/Wordpress/ works just fine.

    I deleted other site and tried to make a new one in new subdirectory,
    but now when I try to reach the dashboard for that site
    http://www.arsov.net/Wordpress/damjana/wp-admin/
    I got error message that the site redirection is broken. ( it is in slo language, hard to translate.. )

  16. Arsov
    Member
    Posted 2 years ago #

    also just crossed my mind, maybe I installed network with link instead of subdirectories option. Is there any way to change that after network is installed?

  17. maybe I installed network with link instead of subdirectories option.

    Open up wp-config.php.

    What does the define say for Subdomain? False means you're using subdirectories :)

    Is there any way to change that after network is installed?

    Yep: http://codex.wordpress.org/Multisite_Network_Administration#Switching_network_types

  18. Arsov
    Member
    Posted 2 years ago #

    Thanks I checked this, yes, I obviously use subdirectories. so there no need to change network.

    Still doesn't work. when I try to reach dashboard of a new site, I get the picture of my basic wordpress site that I made before I added network. the basic site had no subdirectories, it is directed to the Worpress directory. If I click on visit for that new site I got message that there is no index file.

    That's all happened after I made subdirectory with the name I wrote in the link section for the add new site. ,, before that I got error while trying to reach dashboard for that new site.

    I'm not sure if I did something wrong or I misunderstood how this should work.

  19. A ... picture?

    Okay you've certainly confused me :) Let's go back to the begining.

    How can I make additional independent pages with WP on my server without overriding my home page. Is there any relatively simply way to do that?

    Answer: Not really well with Multisite. It's tetchier. Now you CAN install Multisite 3.5 in a subfolder, and have in later 'run from root' HOWEVER it's actually something you want to set up before turning on multisite. Why? Multisite is tetchier.

    Tom's advice is not incorrect at all, it's just that Multisite doesn't work entirely as expected, due to how it saves the domain name and folder path in the DB. The 'easiest' thing would be install in root (yes, I know) and make a holding page on WP for your front-page.

  20. Arsov
    Member
    Posted 2 years ago #

    Hm.. hm.. hm... So, there is still an old way available, mew installation for every new page. :/ as you said that multisite doesn't work as it was expected, that probably means that developers are trying to solve this issues. I thought it was only my lack of knowledge. I'm really not so keen to install WordPress on root ( yes, you know ;) )

    Is there any alternative solution for my issue?

  21. It's actually working as it should, it's not not working as people want it to. It's totally functional, and you totally CAN do this. It's just messy.

    Do you want to use subdomains or subfolders for your subsites?

  22. Arsov
    Member
    Posted 2 years ago #

    Thanks,
    I switched to subdomains and now everything works as it should. :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.