WordPress.org

Support

Support » Plugins and Hacks » DON'T UPGRADE! Plugin failed after upgrade

DON'T UPGRADE! Plugin failed after upgrade

Viewing 15 replies - 1 through 15 (of 17 total)
  • Hello CindyGoBeyond what are the errors that you see when you try to revert back to an earlier version?

    The HTTP response test get a false http status (403)

    I get the same error after upgrade and I deleted my JOB then recreated it. No change. However, I won’t downgrade. I’ll wait until this is fixed and run manual DB backups.

    Plugin Author Daniel Hüsken

    @danielhuesken

    Did you have special entry for restricting access to wp-cron.php?

    The Plugin starts the job with a call to wp-cron.php now, because there often problems with themes if i did it over the frontend.

    I get the same error. From Information tab on settings page:

    Server Self Connect: The HTTP response test get a error “Operation timed out after 5 seconds with 0 bytes received”The HTTP response test get a false http status ()The HTTP response gives back the false body “”

    I don’t think I have any special restrictions for wp-cron.

    I’m getting multiple warnings on database dump attempts and on dropbox upload. The whole operation takes more than 20 minutes now (used to be a couple of minutes), mostly by a very long “database dump attempt”. Pahs and usernames xxx-ed for security reasons.

    [INFO] BackWPup version 3.0.7; WordPress version 3.5.1; A project of Inpsyde GmbH developed by Daniel Hüsken
    [INFO] This program comes with ABSOLUTELY NO WARRANTY. This is free software, and you are welcome to redistribute it under certain conditions.
    [INFO] BackWPup job: Weekly backup; DBDUMP+FILE+WPEXP+WPPLUGIN
    [INFO] BackWPup cron: 0 3 * * 0; śr, 17 kwi 2013 @ 10:24
    [INFO] BackWPup job started manually
    [INFO] PHP ver.: 5.3.17; cgi-fcgi; Linux
    [INFO] Maximum script execution time is 15 seconds
    [INFO] MySQL ver.: 5.1.68-cll
    [INFO] curl ver.: 7.24.0; OpenSSL/1.0.0
    [INFO] Temp folder is: xxxx
    [INFO] Logfile folder is: xxx
    [INFO] Backup type is: archive
    [INFO] Backup file is: xxx
    [17-kwi-2013 10:24:36] 1. Try to dump database …
    [17-kwi-2013 10:29:40] WARNING: Job restart due to inactivity for more than 5 minutes.
    [17-kwi-2013 10:29:40] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with that of OpenCloud\DNS\DnsObject::Create()
    [17-kwi-2013 10:29:40] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with that of OpenCloud\DNS\DnsObject::Update()
    [17-kwi-2013 10:29:40] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with that of OpenCloud\DNS\DnsObject::Delete()
    [17-kwi-2013 10:29:40] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with that of OpenCloud\DNS\DnsObject::UpdateJson()
    [17-kwi-2013 10:29:40] 2. Try to dump database …
    [17-kwi-2013 10:34:44] WARNING: Job restart due to inactivity for more than 5 minutes.
    [17-kwi-2013 10:34:44] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with that of OpenCloud\DNS\DnsObject::Create()
    [17-kwi-2013 10:34:44] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with that of OpenCloud\DNS\DnsObject::Update()
    [17-kwi-2013 10:34:44] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with that of OpenCloud\DNS\DnsObject::Delete()
    [17-kwi-2013 10:34:44] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with that of OpenCloud\DNS\DnsObject::UpdateJson()
    [17-kwi-2013 10:34:44] 3. Try to dump database …
    [17-kwi-2013 10:39:46] WARNING: Job restart due to inactivity for more than 5 minutes.
    [17-kwi-2013 10:39:46] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with that of OpenCloud\DNS\DnsObject::Create()
    [17-kwi-2013 10:39:46] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with that of OpenCloud\DNS\DnsObject::Update()
    [17-kwi-2013 10:39:46] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with that of OpenCloud\DNS\DnsObject::Delete()
    [17-kwi-2013 10:39:46] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with that of OpenCloud\DNS\DnsObject::UpdateJson()
    [17-kwi-2013 10:39:46] 1. Trying to make a list of folders to back up …
    [17-kwi-2013 10:39:47] Added "wp-config.php" to backup file list
    [17-kwi-2013 10:39:47] 560 folders to back up.
    [17-kwi-2013 10:39:47] 1. Trying to create a WordPress export to XML file …
    [17-kwi-2013 10:39:50] Added XML export xxx with 2,10 MB to backup file list.
    [17-kwi-2013 10:39:50] 1. Trying to generate a file with installed plugin names …
    [17-kwi-2013 10:39:50] Added plugin list file xxx to backup file list.
    [17-kwi-2013 10:39:50] 1. Trying to create backup archive …
    [17-kwi-2013 10:39:50] Compression method is ZipArchive
    [17-Apr-2013 08:40:41 UTC] PHP Fatal error:  Maximum execution time of 15 seconds exceeded in xxx/backwpup/inc/class-create-archive.php on line 268
    [17-kwi-2013 10:40:41] ERROR: Maximum execution time of 15 seconds exceeded
    [17-kwi-2013 10:40:41] Script stopped! Will start again.
    [17-kwi-2013 10:40:41] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with that of OpenCloud\DNS\DnsObject::Create()
    [17-kwi-2013 10:40:41] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with that of OpenCloud\DNS\DnsObject::Update()
    [17-kwi-2013 10:40:41] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with that of OpenCloud\DNS\DnsObject::Delete()
    [17-kwi-2013 10:40:41] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with that of OpenCloud\DNS\DnsObject::UpdateJson()
    [17-Apr-2013 08:41:57 UTC] PHP Fatal error:  Maximum execution time of 15 seconds exceeded in xxx/backwpup/inc/class-create-archive.php on line 268
    [17-kwi-2013 10:41:57] ERROR: Maximum execution time of 15 seconds exceeded
    [17-kwi-2013 10:41:58] Script stopped! Will start again.
    [17-kwi-2013 10:41:58] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with that of OpenCloud\DNS\DnsObject::Create()
    [17-kwi-2013 10:41:58] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with that of OpenCloud\DNS\DnsObject::Update()
    [17-kwi-2013 10:41:58] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with that of OpenCloud\DNS\DnsObject::Delete()
    [17-kwi-2013 10:41:58] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with that of OpenCloud\DNS\DnsObject::UpdateJson()
    [17-Apr-2013 08:43:28 UTC] PHP Fatal error:  Maximum execution time of 15 seconds exceeded in xxx/backwpup/inc/class-create-archive.php on line 268
    [17-kwi-2013 10:43:28] ERROR: Maximum execution time of 15 seconds exceeded
    [17-kwi-2013 10:43:28] Script stopped! Will start again.
    [17-kwi-2013 10:43:29] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Create() should be compatible with that of OpenCloud\DNS\DnsObject::Create()
    [17-kwi-2013 10:43:29] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Update() should be compatible with that of OpenCloud\DNS\DnsObject::Update()
    [17-kwi-2013 10:43:29] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::Delete() should be compatible with that of OpenCloud\DNS\DnsObject::Delete()
    [17-kwi-2013 10:43:29] STRICT NOTICE: Declaration of OpenCloud\DNS\PtrRecord::UpdateJson() should be compatible with that of OpenCloud\DNS\DnsObject::UpdateJson()
    [17-kwi-2013 10:43:29] 1. Try to send backup file to Dropbox …
    [17-kwi-2013 10:43:30] Authenticated with Dropbox of user xxx
    [17-kwi-2013 10:43:31] 991,26 MB available on your Dropbox
    [17-kwi-2013 10:43:31] Uploading to Dropbox …
    [17-kwi-2013 10:47:07] WARNING: is_file() expects parameter 1 to be string, resource given
    [17-kwi-2013 10:47:11] ERROR: Uploaded file size and local file size don't match.
    [17-kwi-2013 10:47:11] 2. Try to send backup file to Dropbox …
    [17-kwi-2013 10:47:12] Authenticated with Dropbox of user xxx
    [17-kwi-2013 10:47:12] 864,69 MB available on your Dropbox
    [17-kwi-2013 10:47:12] Uploading to Dropbox …
    [17-kwi-2013 10:47:12] WARNING: is_file() expects parameter 1 to be string, resource given
    [17-kwi-2013 10:47:14] ERROR: Uploaded file size and local file size don't match.
    [17-kwi-2013 10:47:14] 3. Try to send backup file to Dropbox …
    [17-kwi-2013 10:47:15] Authenticated with Dropbox of user xxx
    [17-kwi-2013 10:47:15] 864,69 MB available on your Dropbox
    [17-kwi-2013 10:47:15] Uploading to Dropbox …
    [17-kwi-2013 10:47:15] WARNING: is_file() expects parameter 1 to be string, resource given
    [17-kwi-2013 10:47:18] ERROR: Uploaded file size and local file size don't match.
    [17-kwi-2013 10:47:18] 2 old logs deleted
    [17-kwi-2013 10:47:18] Job done in 1362 seconds.

    I got the same error after downgrading. One really early version did not give the error, but simply never made a backup.

    Until the upgrade, the plugin worked beautifully (and multiple times).

    Uninstall any 3.x installs from your plugins and revert back to version 2.1.17. Manually install folder content via FTP to /public_html/wp-content/plugins/backwpup/ and reactivate in WordPress. This is the last working version without complications. Unfortunately, the current 3.x family is utterly a PHP developer’s fail without any promise of soon resolve.

    I’m a budding hosting reseller and I’ve been doing site upgrades for the last few days. This plugin has made it onto my list of must-haves for my clients (and me as their admin). Starting on fresh WordPress setups, I’ve added the plugin via search and install in WordPress itself since I started. With a quick look, it looks as though 3.0.8 is installed, and running as it should, on a number of my sites.

    The eighth setup (begun about 12-13 hours ago now, actually) is throwing the 403 error same as everyone else. Because the setup was fresh, I had no problems switching databases to try again – with the same result. I tried rolling back to the version before 3.0.8 via FTP but, when I did I bumped into another problem: On clicking ‘run’ it would say something along the lines of ‘job started,’ then nothing else.

    I don’t think I’d tried to upload 3.0.8 via FTP but that’s running now, just in case it will help. I’ll post again once it’s done and I’ve had time to test.

    The update via FTP didn’t work for that particular site.

    Skipping ahead to a new website, new setup, (same server and setup process) it worked as it should – runs jobs fine.

    I don’t believe there is anything in the troubled site that is any different from the rest I’ve done so I’m not sure why it would work on all the others. Any ideas?

    Seems as though the thorn in my side on the problematic site is Block Bad Queries, in case anyone else is using it as well. I’m still not sure why there isn’t a clash on the other sites but perhaps it’ll help in the troubleshooting.

    Plugin Author Daniel Hüsken

    @danielhuesken

    @avwebworks: please mal me at d dot huesken at inpsyde dot com than we can look what happens. Normely for that is the PRO Support.

    Hi,

    I seem to have the same issue on a WP 3.3.2 install: The HTTP response test get a error “Operation timed out after 15008 milliseconds with 0 bytes received”The HTTP response test get a false http status (). Is there a solution to this problem?

    BTW No Block Bad Queries installed.

    I have installed ver. 3.0.10 on two subdomain on that same server:
    1. subdomain – plugn work fine
    2. subdomain – plugin says: The HTTP response test get a false http status (403). I reinstalling and didnt work

    Hi,
    I’m using WP 3.5.1 and backwpup 3.0.12 – and I have the same issue.
    Trying to all relevant .htaccess files didn’t help.

    Is there a fix coming soon?

    OK, my issue was solved, and it was my fault. I use a security cloud service and I block external access to wp-cron.php, but allow it to the IP address of the hosting server itself.
    My hosting company recently moved my site to a new server, and I didn’t update this security service to allow access to wp-cron.php from the IP address of the new server.
    Once I allowed that – the job is running fine.
    Sorry for my misleading mistake.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘DON'T UPGRADE! Plugin failed after upgrade’ is closed to new replies.