Support » Plugin: Yoast SEO » Don't update to 3.x, it's a disaster!!!

  • What the hell are you doing? Yost SEO was one of the best plugins for WordPress. With the update to 3.x this plugin is a complete mess. Why you have changed the core of the plugin? This is one of my most terrible experiences with a plugin.

    This is a warning to all users of Yost SEO, do not update to 3.x! I have used WP rollback to get back the version 2.3.5. I don’t have time for this nonsense to get used to a new layout and missing meta descriptions.

    You just destroyed your best plugin and lost confidence forever! I will never update your plugin again and will see if I can use another one instead.

Viewing 4 replies - 1 through 4 (of 4 total)
  • 100% true. I need to figure out how to rollback now. Don’t have time for this.

    Use the plugin WP Rollback, just install it and then you can select a previously version of Yost SEO (2.3.5 recommended!)

    thanks! i have tried it and it works again! i have told it on the fb groups in the Netherlands about this salution. Thanks again!

    Plugin Support benvaassen

    (@benvaassen)

    Hi @mike12oo,

    Sorry it’s taken us over a year to get back to you on this one. Almost a year has passed since your review. We’ve made a ton of changes to Yoast SEO and would like to invite you to give the plugin a new try.

    If you want to learn more about the plugin before installing it, we feel our knowledge base is the best place to start.

    Thanks for giving the plugin another try!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Don't update to 3.x, it's a disaster!!!’ is closed to new replies.