[resolved] Don't understand! Error with wildcard dns? (6 posts)

  1. danielwerner
    Posted 3 years ago #


    Please help, I'm getting gray hairs over here.

    I'm trying to install a fresh install of WordPress multiuser. I've done the following:

    1. Installed wordpress (plus databases etc). It's located on public_html/multiuser (as an example).
    2. Added the multiuser-true-part in the config.php.
    3. Added a wildcard subdomain via cpanel. It says *.multiuser.com and points to public_html/multiuser, the same path as where the config.php is located. When I check dns records in cpanel there is a wildcard dns setup there, which points to my webhosts server.

    BUT! When I login into the wordpress installation, and click network settings, choose subdomains and then clicking install, that's where it all goes bad. I get the an error message saying that my joker-dns probably wasn't setup right since wordpress tried to create a test-subdomain and got a "could not resolve"-error.

    This error only comes once, if I click on network configuration again I get another warning saying that wordpress already found an existing network.

    I tried going through with everything, including adding the stuff into .htaccess and config.php, but when I try to add a new site via the register-button, the install says everything was finished, and I get a welcome-email, but nothing was created and I get a "page not found" when trying to access the recently created site (for example testblog.multiuser.com).

    PLEASE help, I don't know what I'm missing. I've read the codexes on wordpress.org several times.

  2. danielwerner
    Posted 3 years ago #

    This is what my DNS record (via cpanel) looks like:

    multiuser.com. 14400 IN A *server IP*
    localhost.multiuser.com. 14400 IN A
    mail.multiuser.com. 14400 IN CNAME multiuser.com
    http://www.multiuser.com. 14400 IN CNAME multiuser.com
    http://ftp.multiuser.com. 14400 IN CNAME multiuser.com
    webdisk.multiuser.com. 14400 IN A *server IP*
    multiuser.com. 14400 IN TXT *a bunch of different parameters*
    *.multiuser.com. 14400 IN A *server IP*
    webdisk.*.multiuser.com. 14400 IN A *server IP*

  3. Is WP installed in a subfolder? Because that won't work with what you're trying to do, unless you use WP 3.5 and allow the main site to be example.com (and not example.com/wordpress)

  4. danielwerner
    Posted 3 years ago #

    Yep, it's installed in a subfolder on the ftp (I mean, it's not the root), but not on the domain. Won't that work? Because I've managed to get it to work before, I just reinstalled because I needed to update everything (I figured it was easier to just reinstall).

    I use WP 3.4.2 and the site is it's own domain, just http://multiuser.com (as an example).

    Will that work in 3.5 you mean? It should be here soon, so I can hang on a few days?

  5. Yep, it's installed in a subfolder on the ftp (I mean, it's not the root), but not on the domain.

    Depends. If the root of your domain is the multiuser folder, you should be okay. If you mean you did the 'Giving WordPress it's own directory' then you have to wait for 3.5 :)

  6. danielwerner
    Posted 3 years ago #

    It works now. I contacted my host, apparently the wildcard dns zone-file was corrupt. Weird.

    Thanks though! Hope this helps anyone else with the same issue.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.