Support » Plugin: Wordfence Security - Firewall & Malware Scan » Don’t See Scan Scheduling Options

  • Hi, we’re having trouble with a site getting a lot of physical memory faults, usually at around the same time of day. It appears this may coincide with when WordFence may be performing scheduled scans. This would make sense, as the site is almost 10GB, so guessing this puts a lot of strain on the server. We have WF set to use up to 256MB of memory, not sure if this is enough/too much.

    But in trying to determine when the cron tasks are scheduled, and how to modify them, I am not seeing any of the options described in the documentation as follows:

    Wordfence displays the current time your WordPress site uses at the top of the scan scheduling page. You can go to the Settings/General menu to change your timezone. Use the links provided on the scan scheduling page in Wordfence as shortcuts to select scan times. Try clicking the links several times to advance the time. You can also manually select scan start times for each day.

    When I go to the “Scan Options and Scheduling” page, I do not see the time at the top nor do I see any way to adjust it. I’ve looked very carefully, and am using current WF 7.2.5.

    – What am I missing and what do I need to do to see and/or change the scheduled time so it’s not in prime time for our site (currently about 9am EDT)?? Need it to fire in the middle of the night.

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hey @kennyll,

    My apologies for any confusion, the Manually schedule scans feature is a Premium-only feature. I’ll speak with some colleagues to see if we can make this more clear in the documentation.

    https://www.wordfence.com/help/scan/scheduling/

    Thanks,

    Gerroald

    Thread Starter KennyLL

    (@kennyll)

    Thanks for the reply. Hmm, I was thinking ‘manually scheduled scans’ were different from the auto scans. The documentation seems to indicate that the frequency (how often) scans run is what the Premium upgrade offers.

    If what you’re stating is true, that is unfortunate and very misleading according to what the documentation states.

    – So we are stuck with Wordfence scheduling its scans at a random and very inopportune time unless we pay for a premium subscription?

    The documentation goes so far as to recommend scheduling scans for the middle of the night, but for a free user its scheduled at 9am (which is prime-time for our site)?!? I suppose that’s a really good way to force people to upgrade, but just seems a bit shady.

    – Are there any other ways (programmatically) to alter this, or any, cron tasks in WordPress??

    Thanks.

    Hey @kennyll,

    My apologies for the trouble. We definitely aren’t trying to be misleading, and I’ve spoken with the staff about this issue this morning.

    One colleague was wondering if you might have the Query Monitor plugin installed? This plugin is helpful for query troubleshooting, but it causes all database queries to be saved, which uses lot of memory during Wordfence scans. We recommend disabling it when you are not actively using it.

    Another option is to deactivate and reactivate until you reach a reasonable time for the site. Wordfence randomly fetches the scheduled scan times from our server.

    I hope this help.

    Thanks,

    Gerroald

    Thread Starter KennyLL

    (@kennyll)

    Hi Gerroald, thanks for the response.

    We are not using Query Monitor (had never heard of it).

    – So to be clear, you’re stating that whenever we deactivate & reactivate WF, a different randomly generated scheduling may/will be applied to all WF cron tasks??

    – Does the time that we reactivate WF have anything to do with the scheduling, or is it all completely random?

    – Would we be able to see the newly applied time by checking the ‘Diagnostics > Cron Jobs’ tab?

    When I check the current ‘Cron Jobs’ tab, it appears to only show jobs that have not run yet, but are scheduled to. Is this correct? Any way to see past jobs to see if the coincide with our server memory errors (I’ve written down the currently scheduled ones)?

    I see a couple main WF cron jobs listed:
    A) wordfence_daily_cron – this is scheduled for tomorrow at 9am EDT.
    B) wordfence_start_scheduled_scan – this is scheduled for 5/10 & 5.13 at 2:20am EDT.

    Can you let me know the difference between what those 2 do? The one at 9am EDT is our main concern, as that coincides with when email blasts are sent out that drive a lot of legitimate traffic to the site. Wondering if the traffic hitting while WF is busy is causing the issues.

    Thanks for the additional insight here.

    Hey @kennyll,

    – So to be clear, you’re stating that whenever we deactivate & reactivate WF, a different randomly generated scheduling may/will be applied to all WF cron tasks??

    It will adjust the cron jobs that set the time to run such as daily and hourly. Though it may take some trial and error to get the results you’d like.

    – Does the time that we reactivate WF have anything to do with the scheduling, or is it all completely random?

    Once Wordfence has activated it sends a fetch request to our server. The time of activation doesn’t have anything to do with what time is set, though we do programmatically try to evenly disperse them to avoid overloads.

    – Would we be able to see the newly applied time by checking the ‘Diagnostics > Cron Jobs’ tab?

    Yes.

    Any way to see past jobs to see if the coincide with our server memory errors (I’ve written down the currently scheduled ones)?

    There’s isn’t a way to see this in Wordfence. There are plugins out there to help log cron jobs. However, you can view the activity logs in Wordfence > Scans then click one of the Activity Logs options found on the right top of the most recent scan results. You can search the logs for Scheduled Wordfence scan starting.

    A) wordfence_daily_cron – this is scheduled for tomorrow at 9am EDT.

    This is the one that’s going to control your daily scan time. When you reactivate Wordfence you’ll notice the time change. Note this runs depending on the needed traffic to trigger it, and the scan can run up to an hour after being triggered depending on the current server loads.

    Please let me know if this helps.

    Thanks,

    Gerroald

    • This reply was modified 2 years, 8 months ago by WFGerroald.
    Thread Starter KennyLL

    (@kennyll)

    Hi Gerroald, thanks for the thorough reply here.

    Well, we’ve disabled & re-enabled WordFence a number of times over the last week, but the ‘wordfence_daily_cron’ time always ends up being somewhere between 11am-1pm our local time (PST). As 12pm noon is our peak traffic time of the day, these times are just far from ideal.

    So, unfortunately, we’ve just had to leave WordFence disabled for now. Hopefully at some point in the future it will actually activate at a time a bit more inline with the recommendations (after hours, middle of the night, etc.). But until then, we’ve had to weigh the load on the server vs. the security that WF adds.

    But can you let me know what the ‘wordfence_start_scheduled_scan’ cron is doing? Maybe it’s just the name that was throwing me…

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Don’t See Scan Scheduling Options’ is closed to new replies.