Support » Plugin: WPtouch Mobile Plugin » Don't see link back to mobile version

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author BraveNewCode Inc.


    It sounds as if you have a caching plugin serving cached mobile pages to your desktop. You may configure your caching plugin not to cache mobile pages nor to serve cached pages when mobile devices are detected. To do so, enter the user agents found under Advanced Options > Custom User-Agents to the “rejected user agents” areas in your caching plugin’s settings. Remember to clear your plugin, browser, and device caches before retesting.

    But I am not browsing the website on a desktop computer. It happens on a phone. And of course it happens when I test in on the desktop computer too. And change the settings on the phone? Or is this a WPTouch settings?

    One thing I noticed is when I hover over the link on a desktop, it says javascript return false. But I looked at some other sites that were posted here and the link says some webaddress?wptouch_switch=desktop&redirect

    I see that I need to have the wp_footer() inside my desktop themes footer. I found this post here. In the advanced settings there is a little red question mark next to ” 1st visit mobile users will see desktop theme” and if you click it, it says “When this option is checked, users will see your regular site theme first, and have the option in your footer to switch to the WPtouch mobile view. They’ll be able to change back and forth either way. Make sure you have the wp_footer(); function call in your regular theme’s footer.php file for the switch link to work properly.”

    Although I don’t have this checked, you need this in the footer for the user to switch back and forth which is easy to overlook.<?php wp_footer(); ?>

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Don't see link back to mobile version’ is closed to new replies.