WordPress.org

Support

Support » How-To and Troubleshooting » Don’t have permission: admin-ajax.php (Add new Category)

Don’t have permission: admin-ajax.php (Add new Category)

  • palmettostar
    Member

    @palmettostar

    I recently upgraded my WP from 2.0 to the newest version; I followed the instructions exactly as they say. I’ve had various problems however since upgrading.

    The first problem I have is the one where when I go to write up a new post, I cannot type anything in the text box.

    The second problem I have is that I keep receiving the do you want to navigate away from this page box whenever I click on the tabs on my write page.

    The most recent error I ran into is that when I try to add a new category name via the box on the “write page” it does not add, so I tried to add it via the Manage Categories page and I get the following error:

    Forbidden
    You don’t have permission to access /wp/wp-admin/admin-ajax.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    ——————————————————————————–

    Apache/1.3.36 Server at http://www.these-words.org Port 80

    I’ve searched these things on the forums and the only thing I’ve come up with is adding certain lines to my .htaccess file which I did, and that did not fix these problems. How do I fix this because it’s very irritating.

Viewing 10 replies - 1 through 10 (of 10 total)
  • a lot of wp users have reported this. a possible solution is in this thread:
    http://wordpress.org/support/topic/117993?replies=36
    but if your server is configured so that mod-security cannot be overruled this will not work.
    have you contacted your host yet?

    palmettostar
    Member

    @palmettostar

    No, I haven’t contacted my host yet…what should I tell them when I do contact them? I have tried just about everything I know to fix this and nothing does =/ I never had these problems prior to upgrading, what was changed that is causing all this?

    palmettostar
    Member

    @palmettostar

    Okay, I realized that I added the coding in the .htaccess file for the index-extra.php error I had but didn’t add the mod secuirty one which I just add to the .htaccess file, however do I upload this .htaccess file to my wp-admin folder or do I leave it in my root directory which is /wp ?

    My advise would be upload to the wp-admin folder so it doesn’t interfere with any rewrite rules you would like to add

    I had an Issue as below:

    Forbidden
    You don’t have permission to access /wp-admin/index-extra.php on this server.

    Editing in .htaccess by adding these following part:

    <Files index-extra.php>
    SecFilterInheritance Off
    </Files>

    helped me to fix the issue i faced on /wp-admin/index-extra.php

    Similarly for:

    Forbidden
    You don’t have permission to access /wp-admin/admin-ajax.php on this server.

    I had to add following part in .htaccess

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    to solve the issue of /wp-admin/admin-ajax.php

    hakre
    Member

    @hakre

    The background is more discussed in this Thread, my Post gives you a better fix to the problem:
    http://wordpress.org/support/topic/117993/page/2?replies=47#post-623051

    Great, it worked to me, thanks!

    I try everything post in this site and nothing works for me.

    Finally I try this and works for me! :

    There is a bug in WordPress v2.1.3 and a few prior versions that may prevent you from adding categories to your WordPress blog.  
    
    When you attempt to add a category, the error message “You do not have permission to do that” will appear in a pink box.
    
    To solve this problem in Internet Explorer 7 (IE7):
    
    Click the IE7 “Tools” button, then select the “Internet Options” menu item.
    Go to the “Security” tab.
    Ensure the “Internet” zone is selected.
    Click the “Custom Level” button.  The “Security Settings - Internet Zone” dialog will appear.
    Scroll down the options until you find the “Scripting” section.
    Under “Active Scripting”, select the “Disable” option.
    Click the “OK” button.  The “Security Settings - Internet Zone” dialog will close.
    In the “Internet Options” dialog, click the “OK” button.
    Press Ctrl+F5 to force refresh the current web page or open a new browser window.
    
    IMPORTANT:  Remember to reset the “Active Scripting” option back to “Enable” when you are finished adding WordPress categories, otherwise you will find that many other web pages will break!

    thanks to http://www.devtopics.com/

    I HAVE THE SOLUCION FOR THE PROBLEM OF CATEGORIES: You don’t have permission to access /wp-admin/admin-ajax.php !!!!!!!!!!

    1. Go to the “wp-admin” folder
    2. Open (or create) the file: .htaccess
    (don’t forget the incial dot)
    3. write at the final of this file:

    <IfModule mod_security.c>
    SecFilterInheritance Off
    </IfModule>

    4. THATS ALL!!!

    mccormicky
    Member

    @mccormicky

    jmalien: thank you!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Don’t have permission: admin-ajax.php (Add new Category)’ is closed to new replies.