Support » Plugin: amr users » Don’t get avatars image in list

  • Resolved psn



    I have used your plugin several years and we have a list including users avatars. These avatars is working every where in our wp site but not in your plugin and user list. We get the url instead like “/avatars/photo51-150×150.jpg”. Its strange as the image has working in user list before but now we get the URL as above instead of the image in list. Any idea how this can be fixed?


Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author anmari


    The plugin calls the wordpress get_avatar function and outputs what it returns.

    It is working on demo site, so whatever it is, it is specific to your site. Perhaps something (theme, other plugin) is affecting it? Relative urls are not the ‘default’ (see demo site), so that means the site has something affecting the default avatar.

    If it were my site, I would debug it systematically

    starting with any plugins that do any avatar stuff, or my theme if it does any avatar stuff. Once you have found it, let them know that the filter they are applying to the get_avatar function is not returning expected output.

    Just a short question before I start any debugging, Shouldn’t we see the avatars in admin sections regardless what theme we are using front end?

    We are using Twenty Eleven so I don’t think its related to the theme and the only plugin we have regarding avatars is “Avatars” which give our users to have locale avatars for their profile instead of the standards that WP have (like Mystr. This plugin has we used together with yours several years and this Avatars plugin has not been updated for some times. We have also tested to specify full path to the images but that don’t solve the problem as we then get this full path specified.

    Also as I said earlier, we get images for local avatars in post, pages, comments and in sidebars for other plugins where they use avatars so I don’t really thinks we have any clashes with some other plugins.

    I think I have solved it, when I have test some other avatars plugin and I disable and reenable the one we have run for several years the settings for the avatars needs to be redone, ie delete the local path so we get the global and then reenter the local path into the settings for Avatars then all our local images (avatars) is showed correctly in user list :-).

    So we can close this ticket for now.

    • This reply was modified 1 year, 3 months ago by  psn.
Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Don’t get avatars image in list’ is closed to new replies.