Support » Plugin: WP Super Cache » Don’t cache pages for known users

  • When updating to 1.6.8, if the advanced setting “Don’t cache pages for known users” is selected, after the update the selection is replaced with “Disable caching for visitors who have a cookie set in their browser”.

    That is unfortunate. E.g. if you are using Cloudflare there will be a __cfduid cookie set on the domain and WP Super Cache will be disabled for all visitors.

    We can enable the old behavior by manually changing the setting to “Disable caching for logged in visitors. (Recommended)”. It would have been nice if the update script had done that. As it is we will have to manually login to every WordPress website we manage and change this setting after updating.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Donncha Ó Caoimh

    (@donncha)

    @trisager – you’re right. That was never spotted in testing.

    There isn’t now an option that exactly replicates the “known users” setting of previous versions. Known users were logged in users or those that left comments.

    If you’re running multiple installs of WordPress on a server you could replace $wp_cache_not_logged_in = 1; with $wp_cache_not_logged_in = 2; in wp-content/wp-cache-config.php using a shell script.

    BTW – I recommend not using this plugin and Cloudflare caching at the same time. It’s very easy for cached pages to go out of date and not be updated as Cloudflare won’t know the page has updated.

    @donncha – We are not caching html in Cloudflare (it doesn’t do that by default), we use it for security and to deliver static assets over the CDN. That has worked fine with WP Super Cache until now – and still does for websites that have comments disabled.

    For websites that use comments: I suppose the updated version of WP Super Cache will show a cached page to users who leave comments unless “Disable caching for visitors who have a cookie set in their browser” is selected? (Which would completely disable caching because of Cloudflare’s __cdfuid cookie).

    Could the old behavior be brought back as an additional option in a future update? Or is there some other workaround you can suggest?

    This is so wrong. Caching has been disabled on all websites. All websites have some sort of a cookie Google analytics or similar. This should default after the update to “Disable caching for logged in visitors. (Recommended)”

    Plugin Author Donncha Ó Caoimh

    (@donncha)

    You’re right. Unfortunately it’s too late to change it now.

    Adnan Khan

    (@adnan770)

    It resulted in weeks of googling and php-fpm and nginx tweaking for me 🙁

    Kindly have pity on us poor sysadmins while making such drastic change in the future.

    Just found this setting. Set it to “disable caching for logged in users”. and the site is fine. Its a heavy traffic website that is running on meager resources.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.