Support » Plugin: WP Mail SMTP by WPForms » Don’t buy, not maintained

  • I’ve been waiting months for them to make very basic fixes to the plugin to allow it to use Amazon SES in the Sydney region, which is the sole reason I bought it.

    It doesn’t support this, and I’ve informed them twice of the problem and where in the plugin to fix, right up to the lines of code, and they’ve said the usual “we’ll look into it” etc, and they haven’t made any new versions of the plugin for months regardless. Still sat on version 1.8.1 (oh and their site doesn’t even have the foresight to show the current available premium version — so you have to download it each time you want to check if its a new version).

    The premium version of the plugin should be treated as unmaintained, unsupported, and unusable, and so the free version likely should be too, until they show actual signs of effort into maintaining their product in working condition. Don’t waste your money.

Viewing 1 replies (of 1 total)
  • Plugin Support Jess Quig

    (@jquigam)

    Hi @4mationroger,

    I’m sorry for your frustration here!

    The issue you’ve described is under active development, but there have unfortunately been roadblocks along the way. I apologize for any trouble caused by these delays!

    We’ve worked hard to provide a product that helps WordPress users of all experience levels delivery site emails reliably, and continue to expand and improve — and provide the best possible support along the way. And so I’m sorry that this option you’re looking for has not been able to get added yet.

    We’re continuing to work on the next rounds of updates, and I’ve asked our team to reach out to you directly when this particular new option is ready.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this review.