WordPress.org

Support

Support » How-To and Troubleshooting » Done, but with errors on page.

Done, but with errors on page.

Viewing 2 replies - 1 through 2 (of 2 total)
  • esmi

    @esmi

    Forum Moderator

    Done, but with errors on page

    If you’re using IE, this message indicates that one of your page’s javascript files has 1 or more errors in it. That’s quite a separate issues to validation issues.

    And, yes, you do have rather a lot of errors (215 to be exact). A lot of them seem to relate to javascript(s) within your page. If they’re within the theme template files, then they need to be moved out of the page and into external scripts. Otherwise, the javascript could be added by plugins.

    The page also shows instances of old, invalid markup (uppercase instead of lowercase) and deprecated attributes/tags such as font, ‘align’, ‘center’ etc.

    If you’re creating post/page content in an HTML editor and then pasting that into WordPress, stop. Your HTML editor is old and outdated. Create your content in WordPress itself.

    If these errors are coming from your theme rather than your content, and you have created or customised the theme, you need to go back into your template files and correct your markup. If you haven’t customised this theme and you don’t have the technical skills to do so, then you need to change themes and/or look for some up-to-date plugins.

    I have a error on my blog with the icon at the bottom left page or post. When I click on the page I get
    Webpage error details

    User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SearchToolbar 1.1; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
    Timestamp: Fri, 25 Jun 2010 01:56:36 UTC

    Message: ‘document.getElementById(…)’ is null or not an object
    Line: 3
    Char: 2
    Code: 0
    URI: http://jamsource.net/beautifulboldcurves/wp-content/themes/inuit-types/library/js/suckerfish.js

    Whats in blod is the visible error. I also cant add links to my pages or post when i click on the link it gives me an 404 error. Please he;p and resolve this problem as soon as possible.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Done, but with errors on page.’ is closed to new replies.