Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » domain/ngg_tag/tag page doesn’t work

  • Hi,
    It seems, that tge plugin generate urls with the following structure:
    domain/ngg_tag/tag
    but unfortunately, the majority of these urls-s do not work, I mean, these do not open, only try to open and stongly disturb the hosting service.
    So there is no “no images were found” error message or 404 page.

    Example: http://tothzoltan.com/ngg_tag/fem

    Either Nexgtgen Gallery plugin or WordPress are up to date.

    Please be so kind and help to fix it.

    Thank you very much!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author photocrati

    (@photocrati)

    @webreneszansz – The pages that are at those addresses (ones following the /ngg_tags/ URL segment) are dynamically generated and will not exist unless someone else has or is visiting the page via a Tag Cloud link.

    Thanks!

    – Cais.

    Hi,

    Thank you, but how can I eliminate this problem? Because the link work properly in case of some tags:

    http://tothzoltan.com/ngg_tag/fa/ -> okay
    http://tothzoltan.com/ngg_tag/ag/ -> okay

    It works also properly, if I check the not existing tag of “valami”

    http://tothzoltan.com/ngg_tag/valami/ -> 404 – no images were found -> okay

    I have only problem, if the sytem generate the mentioned links for existing tags, but the majority of these links do not work, and instead of the expected result of 404 page, these pages / links are not able to open and based on the hosting provider, these debit the hosting server very stongly.
    Why is the result in this case the unsuccessful trying of the open, insted the of the expected 404 page?

    http://tothzoltan.com/ngg_tag/fem -> wrong
    http://tothzoltan.com/ngg_tag/arc -> wrong

    I added tags to the images due to seo considerations, but I don’t use the tag cloud gallery option.

    Thank you very much!

    Plugin Author photocrati

    (@photocrati)

    @webreneszansz – There does appear to be cases where these /ngg_tags/ URL segments are being generated although we do not have a reason for this to happen as they should only be generated / dynamically created when a visitor follows a tag cloud link.

    It may be a case where you will need to adjust your site’s SEO mechanisms (SEO plugin, robots.txt file, etc.) to exclude those URLs from the search engine’s reference.

    Thanks!

    – Cais.

    Hi,
    Thank you, but if these pages would be simple non existing pages, that the standard 404 page method would be great solution.
    But if I setup 404 to main page redirection, it doesn’t work, because these pages cannot open, these only try to open.
    Please be so kind and check the concrete links above.
    Thank you very much!

    Plugin Author photocrati

    (@photocrati)

    @webreneszansz – The links above you referenced are being treated as 404 pages … and once rendered are showing the site’s “home” page which is a default expected behavior in many cases.

    Thanks!

    – Cais.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘domain/ngg_tag/tag page doesn’t work’ is closed to new replies.