WordPress.org

Forums

No images when viewing site remotely (7 posts)

  1. inthebay
    Member
    Posted 3 years ago #

    Hello all, I have a few problems that I believe to be fairly minor.
    Critical Info:

    Windows 7 box, fresh WAMP install, fresh wordpress install. Settings are essentially default.

    When addressing my site, I see this: [just click the blue text, forget syntax to name the link.]

    http://imgur.com/2AXJU

    I'm not sure what the exact problem is, I'm thinking it could be either my PHP information or something to do with the server itself. Any ideas? When I view the site on /localhost/ it looks fine.

    I'm fairly inexperienced with dealing with coding. Is this simply a PHP redirect issue, something I have to change with my SQL?

    Any advice is much appreciated!

    Thanks a ton,

    CW

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Never use localhost or 127.0.0.0 as site urls if you want to view the site using another computer.

  3. inthebay
    Member
    Posted 3 years ago #

    No, I'm sayin from my server itself it will show the images, when viewing from http://www.site.ca my server will not serve up the images. It throws a "image not found on this server" error.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Did you change the urls in Settings -> General?

  5. inthebay
    Member
    Posted 3 years ago #

    Yes, I have wordpress address as http://localhost, and site address as http://www.mysite.ca

    Looked into what is required, and my server files are in C:\wamp\www\

    How would I address this in the wordpress address box? Changing this to /localhost/wamp/www just broke my install of wordpress :/

  6. inthebay
    Member
    Posted 3 years ago #

    Did a little more digging here, and it seems when a remote viewer trys to view any images on my server, it directs to http://localhost/wp-content/themes/twentyten/images/headers/path.jpg

    Any ideas? My index.php?

  7. esmi
    Forum Moderator
    Posted 3 years ago #

    Both addresses should be http://www.mysite.ca/ See Changing_The_Site_URL.

Topic Closed

This topic has been closed to new replies.

About this Topic