Support » Plugin: WordPress MU Domain Mapping » Domain Mapping WPMU BP 1.7Beta

  • Resolved dasped

    (@dasped)


    Hi,

    Currently using/building WPMU Domain Mapping with BP 1.7Beta.

    Mapping seemed to be working just fine prior to the BP install. Problems that have arisen are as follows.

    With mapped domain (Sub-Site) I can’t post or delete activity streams. If I change back to the sub folder url all seems fine and I can post/delete items from the activity.

    Any idea what may be causing this issue?

    Thanks

    http://wordpress.org/extend/plugins/wordpress-mu-domain-mapping/

Viewing 15 replies - 1 through 15 (of 19 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    Any idea what may be causing this issue?

    How are you running BP on your subsite(s)? (ex. are you using a plugin for that?)

    Hi Ron, Thank’s for the reply.

    I have BP Enable Multiblog enabled in wp-config.

    Full list of details and issues I’m dealing with, maybe this will help:

    WP Install – 3.5.1

    BP Install – 1.7 Beta

    WPMU Enabled (Sub-folders) – BPMB Enabled

    Domain Mapping Configured.

    Network Root = http://www.cyber-networks.co.uk

    Mapped Sub = http://cyber-chat.co.uk

    Current BP enabled Theme: Dynamix – from theme forest

    Mapped sub is managing to auto post updates (New avatar insertion etc) But I can not manually post any activity. I can also not delete any activity.

    Troubleshooting tried: Disabled all plugins – No effect

    In brief:

    Inability to add/delete into activity from a sub-site would appear to be directly linked to domain mapping, as when I revert to sub folder URL, the problem is removed.

    Hope the info helps for a better understanding. Cheers.

    Plugin Author Ron Rennick

    (@wpmuguru)

    You probably need to set your domain mapping settings so the admin area of the site runs under the mapped domain.

    In the source of your page the ajax url is http://cyber-networks.co.uk/wp-admin/admin-ajax.php. By default your browser security blocks posting to other domains.

    OK, thank you for the info,

    I tried that via: /wp-admin/network/site-settings.php?id= & successfully changed the admin url for cyber chat.

    Do I need to edit Domain & Edit under /wp-admin/network/site-info.php?id= too or will that just mess things up?

    I ask because I can still see the url you posted in cyber-chat source.

    Thanks again, for your time and patience.

    Not sure if this may help but it may be relevant?

    Child theme – functions-buddypress.php reads:

    /* Load the default BuddyPress AJAX functions */
    /* We are going to load the ajax from the BuddyPress plugin directory so we always use the latest version */
    require_once( BP_PLUGIN_DIR . '/bp-themes/bp-default/_inc/ajax.php' );

    Also found this tread, again, it may help.

    http://premium.wpmudev.org/forums/topic/ajax-and-domain-mapping-dont-play-well-together

    Plugin Author Ron Rennick

    (@wpmuguru)

    It’s not the ajax php file that the browser security objects to it’s the domain in the URL.

    The way to address the domain in the URL is change your domain mapping settings so the mapped domain admin area runs under the mapped domain (instead of the unmapped one).

    Sounds like a great plan Ron 🙂

    I just have no idea how to go about accomplishing such a feat?

    I know, I know, I guess I’ve just been added to ‘The bane of your life list’. Really sorry to put you out like this but is there any way you could perhaps elaborate a little? After all you did make it all sound, so very easy.

    It quite probably is, just I’m a bit of a numpty when it comes to getting my head around something the first time.

    Thanks.

    Plugin Author Ron Rennick

    (@wpmuguru)

    I just have no idea how to go about accomplishing such a feat?

    The domain mapping settings are Network Admin -> Settings -> Domain Mapping. Uncheck the box that says “Redirect administration pages to site’s original domain”.

    Ahh, I already tried this approach with no success in terms of it resolving the issue – ajax link remains exactly the same within the mapped domain website.

    To be honest also, this really is not an approach I had wanted to take (Should it have resolved the issue). I had presumed that the whole reasoning behind adding enable WP Multiblog to the config was because it offers one login to multi platforms (Sites) for all registered users.

    I really love this plugin too and I don’t think there is any other solution out there that will address this matter for me.

    If I really have to, then of course I would disable redirect & remote login but it would appear even that does not resolve the matter for me.

    Do you perhaps understand why it does not?

    Thank you again for your time.

    Plugin Author Ron Rennick

    (@wpmuguru)

    Possibly the ajax url is being changed by BP to go back to the main site which would explain why the setting is not working for you. Unfortunately I don’t have a solution if that is the case.

    OK Ron, thanks.

    Do you think BP Multi Network may be an answer, if I were to change my philosophy on how the BP networks will work. ie. Separate BP groups/activity etc for each site.

    Would this combat the ajax and allow me to keep remote login switched on?

    How would this cope with bbPress?

    Just trying to figure a way around without blowing my mater plan into oblivion.
    Thanks

    Can’t wrap my head round this Ron, would it not make more sense that it is in fact WP (WPMU)that is changing the URL?

    Plugin Author Ron Rennick

    (@wpmuguru)

    No, it doesn’t make sense to me that WP (multisite or otherwise) is changing the ajax url. WP uses the same ajax url whether or not you have BP running. On the other hand BP may be designed to use a different ajax url in that scenario than what WP typically uses.

    I haven’t had anyone report that ajax was not working with BP Multi Network.

    Thanks Ron.

    I have now gone back to the theme author due to THIS ticket. Pointed out to me by a member of the BP community.

    Biggest nightmare I ever had with an install this, really has beat me around the head.

    Thanks very much for all you help and advice! I will be sure to call back and let you know how I get on.

    Kind Regards.

    Hello again Ron,

    Just a heads up to see if this sparks anything you may feel is related.

    If I add another sub-site via sub folder and do not configure a mapped domain. Post/edit activity & groups works just fine, yet ajax url remains the same.

    So cyber-networks.co.uk/new-site/activity has no posing/editing restrictions.

    As soon as I map a domain via the plugin cyber-newsite/activity I’m obviously hit with the problems because the domains don’t match.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Domain Mapping WPMU BP 1.7Beta’ is closed to new replies.