WordPress.org

Forums

[resolved] Domain mapping points to empty folder on ftp-root but not my subdomain content (4 posts)

  1. regined
    Member
    Posted 2 years ago #

    My domain mapping points to the empty addon-domain folder "newsite.com" on ftp-root but not my subdomain content of http://newsite.primarysite.net

    Here is what I did so far
    1.Installed WP Multisite (in the ftp-root) and MU Domain Mapping (entered the Hostgator Baby account not dedicated IP address)
    2.Created the subdomain http://newsite.primarysite.net (ID #2) under network admin -> add new site. The new site subdomain so far works perfectly fine.
    3. Bought the new domain name “newsite.com” on godaddy and set the nameservers in godaddy to point to my hostgator hosting account
    4.Added a add-on domain on the hostgator cpanel for my newly bought domain “newsite.com”
    5.Did the domain mapping for that new ID # 2 site pointing to the domain “newsite.com”
    6.Now the subdomain http://newsite.primarysite.net (ID 2) gets forwarded to my domain name “newsite.com” BUT the website DOES NOT show me the content and pages of http://newsite.primarysite.net. Instead it shows me the content of the folder “newsite.com” that lies on the ftp-root. That content is cg-bin and ftpquota. That folder got created when I added my new domain “newsite.com” as a addon-domain on hostgator.
    What am I doing wrong here?
    I get the feeling it has something to do with the IP address I entered in the Domain Mapping configuration window? I used the provided hostgator baby plan IP address, it is not a dedicated IP.

    I looked all morning all over the place but I can´t figure it out! Please help!

  2. regined
    Member
    Posted 2 years ago #

    I´m still searching for an answer :-(

    I read something about setting up a A record. Is it possible that this would be a must-do step that I left out?

    And if yes what on earth would I have to put into that simple zone editor on Hostgator?

  3. My domain mapping points to the empty addon-domain folder "newsite.com" on ftp-root but not my subdomain content of http://newsite.primarysite.net

    Well... Okay, that's your problem. It should point to primarysite.net - Remove the Add-on. Use a parked instead

    http://support.hostgator.com/articles/cpanel/what-is-a-parked-domain-how-do-i-create-and-delete-one

  4. regined
    Member
    Posted 2 years ago #

    Mika, thank you so much, that was exactly the problem!

    Once I removed the add-on domain and added PARKED domain for the new domain name instead everything worked just fine now!

Topic Closed

This topic has been closed to new replies.

About this Topic