Support » Networking WordPress » Domain mapping not working after update to 3.1

  • Resolved mistermagoo

    (@mistermagoo)


    I had to make a manual update to 3.1, and I had all pllugins desabled. After that, it was working good, but was still showing an error message that installation needs to be completed.

    Well, I did reactivate the previous plugins, including the wp-domain mapping. Until there it was working good, I could map without problems.
    But I decided to run the automatic update to 3.1, to be sure everything is ok. This time the automatic update worked fine. (Of course I had all plugins deactivated ahead).

    Now, after reactivating wp-domain mapping, I can no longer map any domains.
    I updated this plugin, then removed it, re-installed latest after a fresh download, removed sunrise, re-add sunrise, even changed wp-domain mapping to mu-plugins folder.
    Nada, Niente, nor Caliente! it does no longer map 🙁

    Hope you have an idea what to do, besides to start from scratch a 3.1 and re-multisite it.

Viewing 15 replies - 1 through 15 (of 29 total)
  • Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    You haven’t given any details about what is not working other than “it does no longer map”

    Kinda hard to help there.

    Reinstalling multisite will probably not help. this isn’t Windows on your desktop. An upgrade is the same as a reinstall (essentially).

    And did you *network activate* the domain mapping plugin?

    Hi, sorry for the delay.

    Well, I had network activated “wp-domain mapping” plugin before and now, but I also tryed in normal mode, and within the mu plugin folder.

    Before the second update it was working fine when I added a domain. I could easily change the parameters so that the domain will be mapped and access it’s dashboard.

    IE: changing from : parksite.multisite.com … to: parksite.com

    Then, when you open the section “sites”, it clearly shows which sites are mapped, because they appear under the column “mapped sites”.

    And if I try to open the dashboard of that new mapped site, it opens the multisite login window again in loop –impossible to access the dashboard of it.
    Strangely the previous mapped sites are working, just the new ones are not mapped correctly.

    Hope I provided a better explenation than just: “it doesn’t map anymore”.
    🙂

    Well, I re-installed multisite with a fresh 3.1 installation with a new database. Now the domains mapping menu in settings does not work, but looks like the domains are mapped now: I can see it online with the right domain name, but unfortunately not possible to login to the mapped site. The login window loops.
    I tried several times, with new user and password. Nothing, allways in loop.

    Hope you know what is happening.

    Well,

    Because I have seen tons of threads going the same direction, I decided to go back to 3.05, where I can without problems have my multisite running perfectly.
    I guess 3.1 or the mapping plugin are not alpha but still in beta.

    Hope it will get fixed soon, because 3.1 looks realy cool.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Neither 3.1 nor the domain mapping plugin are in beta. They are full releases.

    I believe I’m having a similar problem. After upgrading to 3.1, redirects still seem to work but I no longer see the [edit] buttons on posts. I discovered that is_user_logged_in() returns false on all domains except for the main domain (blog 1). $current_user is also undefined. Domain mapping fail? Does anyone have a solution to this?

    Not sure if it’s related, but I also noticed the Domain Mapping options got moved from the Super Admin panel to Tools > Domain Mapping on the Single Site Options rather than Network Options.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Upgrade the plugin. I can tell you do not have the most recent version by the location of the menu.

    Great! Thanks for the suggestion, I just upgraded. Unfortunately that didn’t fix the problem of the admin bar/edit links missing when I visit my network sites. Any other ideas? Thanks!

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Are you logged in to the other sites?

    That edit link only shows when you;re logged in.

    Previously, I could log in to WordPress from any site and it showed the edit link on all sites.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Did the remote login option under Domain mapping get UNchecked?

    Cuz that’s what that options does, keeps you logged in.

    Nope it’s definitely checked. The first four options are checked, and the fifth is unchecked.

    Is there anything else I could check? Not opposed to writing debugging code if you can suggest a direction to look..

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Do you have any cookies set in your config file?

    I don’t think so. I just changed the keys via https://api.wordpress.org/secret-key/1.1/salt/ to be sure, and the problem still persists.

    Andrea Rennick

    (@andrea_r)

    Customer Care at Copyblogger Media and Studiopress

    Update your rewrite rules, they did change slightly.

    Go to Network Admin -> network setup.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Domain mapping not working after update to 3.1’ is closed to new replies.