WordPress.org

Support

Support » Plugins and Hacks » NS Cloner - Site Copier » [Resolved] Domain Mapping

[Resolved] Domain Mapping

  • I have installed the WordPress MU Domain Mapping via my cPanel. I first installed it into the public_html-mu directory because the wp-content there has a folder named blogs.dir. That just created error messages, and the Domain Mapping option did not appear in my network admin.

    I then uploaded the wp mu dm files into the public_html/wp-content and the domain mapping appears in my network settings.

    I tried to clone a new site and ns cloner returns an error telling me to choose a source site and give the site a name – fill in the 3 fields. I do this and the same error appears.

    Questions:

    Do I install the wp mu dm into public_html or public_html-mu?

    Do I manually create the blogs.dir folder? (I did, so could this be what is causing the ns cloner issue?)

    Thanks

    https://wordpress.org/plugins/ns-cloner-site-copier/

Viewing 2 replies - 1 through 2 (of 2 total)
  • I’m thinking there’s something wrong someplace, but it may be a function of the sequence in which things have been done.

    My main site, http://thesenioragent.com, has the wp mu dm in settings, but the site I cloned it to, asa-template.thesenioragent.com, does not have domain mapping showing up in settings. This site was created prior to my installation of wp mu dm – is that the reason?

    Thanks again.

    Plugin Author Never Settle

    @neversettle

    We can’t speak to installing the WP MU Domain Mapping plugin, but you should follow that plugins installation instructions directly.

    For cloning, make sure that there are NO domain mapping settings active on the site you are picking to clone.

    You shouldn’t have to create the /blogs.dir/ directory manually. The /blogs.dir/ directory only applies to WP installations before version 3.5. It’s highly unlikely that the /blogs.dir/ directory applies in your case, unless your Multisite installation originated before 3.5 and in that situation it would have been created automatically a long time ago.

    That error in the Cloner most likely means that the site you have selected in Step 1 does NOT have a site name. If that’s the case, you need to go to that site’s dashboard > Settings > General and fill out the Site Title field and save those settings then try the clone again.

    Hope that helps.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] Domain Mapping’ is closed to new replies.
Skip to toolbar