Support » Plugin: WP OAuth Server (OAuth Authentication) » domain.com/oauth/authorize throws a 404

  • Hello,

    I’ve been trying to figure this out. I can’t find anyone else experiencing this issue and I’ve googled and banged my head against this for 4 days. It appeared to be a rewrite issue, then I thought it was because maybe the WordPress API wasn’t enabled, but I can hit the API. How can I fix this?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Have you tried to set access

    domain.com?oauth=authorize

    The reason I am asking is that the API does rely on the permalink structure that WP uses. If the above structure works, please visit wp-admin and then click on Setting->Permalinks. Set the permalinks to something no default.

    Hope this helps but if not, please update this forum and we can go start helping in more depth.

    Thanks

    I received this error
    {"error":"invalid_request","error_description":"unknown request"}

    It is already set to custom structure:

    http://domain.com /index.php/%year%/%monthnum%/%day%/%postname%/

    Plugin Author Justin Greer

    (@justingreerbbi)

    Forum Moderator

    Sorry for the delay.

    Are you able to see http://domain.com/wp-json/ ? The error you are receiving is the error for WP OAuth Server when there is no method to the OAuth 2.0 request at the base level. Be sure that the plugin is enabled. Even try deactivating it and reactivating it.

    There are 2 methods you can be used for the authorizing request for SSO.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘domain.com/oauth/authorize throws a 404’ is closed to new replies.