Support » Plugin: WP QuickLaTeX » Dollar sign not showing up $ \$ 24$, Use for Blog with Ads?

  • Hi there!

    Two questions.
    First Question, I am trying to show the dollar sign in a sentence but it is not showing up when using $ .. $ This is working in quicklatex.com but not in this plugin. All common symbols &%#\ show up except for the dollar sign $. I use gutenberg like this:

    HTML Block:
    [latexpage]

    Paragraph Block
    At first, we sample $ \$ 24$ dollars. Testing all common symbols: $\& \% \$ \# \_ \{ \}$

    Any advice on how I can fix this?

    The dollar symbol does show up if i do this:

    
    \begin{equation} 
    \& \% \$ \# \_ \{ \}
    \end{equation}

    But I want the dollar symbol to be inside a sentence, not in a new line.

    Also, when typing normal sentences, is there a way to simply show the regular ASCII text character $, instead of the image/svg $ ?

    Second Question:
    I see that this plugin and quicklatex.com is for non-commercial use, but could you clarify. Does that mean that it cannot be used for blogs that make any kind of money like through ad revenue?

    Or does it simply mean that monetized blogs can use it as long as the images generated by quicklatex continues to show quicklatex.com upon mouse hover?

    By the way, thanks for the awesome plugin and keep up the good work. 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author advanpix

    (@advanpix)

    Please play with the plugin settings->Advanced-“Exclude $…$”.

    As for second question. Under “commercial” we assume usage on pure commercial websites: companies sites, shops, online courses, etc. We consider monetized blogs as non-commercial.

    Yes, there is an ambiguity in this definition, but usually commercial websites want to remove the “Rendered by QuickLaTeX.com” tool-tip. This is very strong indication of “commercial” use.

    Hi,
    Thanks for clarifying that and for the quick response. I have tried the settings->Advanced-“Exclude $…$” but it is not a working solution because then I cannot inline latex variables in sentences, which is what I am looking for.

    For example, i want to achieve this sentence which has latex variables and a number with a dollar sign all inline in the sentence:

    HTML Block:
    [latexpage]

    Paragraph Block
    At first, we sample $f(x)$ in the $N$ ($N$ is odd) equidistant points around $x^*$ and we have low money, only <strong>$ \$ 24$ </strong>dollars.

    If I activate settings->Advanced-“Exclude $…$”. And try using this symbol instead \[..\] like this,

    Paragraph Block
    At first, we sample \[f(x)\] in the \[N\] (\[N\] is odd) equidistant points around \[x^*\[ abd we have low money, only $ 24 dollars.

    I do not get the latex images all in one sentence. Instead each image variable goes centered in a new line.

    At first, we sample
    f(x)
    in the
    …. etc

    Is there a way to do inline latex variables and show $ symbol?
    thanks,

    Plugin Author advanpix

    (@advanpix)

    Situation with inline equations shown as displayed is a very common issue, not related to QuickLaTeX. Theme on your website adds special CSS style to each image to be shown separately from text, e.g.:
    https://wordpress.org/support/topic/inline-math-not-working/

    Hi,

    Previously, I have already removed “display: block” from my css, which make the image show inline but only when using $ … $

    The CSS in Wp-quicklatex plugin when using $ … $ shows the following which works fine with inline images:
    <img class="ql-img-inline-formula quicklatex-auto-format"

    However, when using
    \[Variable\]
    and also when using

    \begin{equation}
    \end{equation}

    the CSS in Wp-quicklatex plugin shows the following:

    <p class="ql-center-displayed-equation">
    <span class="ql-right-eqno"> whitespace </span>
    <span class="ql-left-eqno"> whitespace </span>
    img class="ql-img-displayed-equation quicklatex-auto-format"

    Which means that regardless of me removing the “display:block” in CSS, the image still shows centered with whitespace at each side.

    So I have not found a way to use settings->Advanced-“Exclude $…$” AND also show a latex variable inline within a sentence.

    Do I need to modify the WP-Quicklatex code or is these a way to natively do this?

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.