Support » Plugin: Matomo Analytics - Ethical Stats. Powerful Insights. » Does’t install with PHP 7.0.33

  • Resolved benbois

    (@benbois)


    Hi there,

    I tried to install your plugin in a server with PHP 7.0.33 and I got this error message:
    Error: This plugin requires a newer version of PHP. Click here to learn more about updating PHP.

    But you wrote that the minimum PHP version is PHP 7.0.
    I don’t understand!

    Cheers

Viewing 6 replies - 1 through 6 (of 6 total)
  • It says 7.2 in the sidebar, just a typo in the main description I’d say. Someone pulled the trigger on this before it was properly cooked. 🙂

    Thread Starter benbois

    (@benbois)

    Thank for your quick reply.

    Then, it is 7.2 or 7.0??

    In a case, I won’t be happy 😉

    If you got the error, then I’d assume 7.2, but I’m not the developer.

    Obviously you would be better off upgrading to 7.2 or 7.3 if that option is available to you. Yes, CentOS are backporting updates, but it’s way out of date at this stage.

    Hi,

    The plugin requires PHP 7.2 (as seen in the readme.txt https://github.com/matomo-org/wp-matomo/blob/4058231c54ef4cd91b5bad14be573474ca7904b7/readme.txt#L8)

    The main text is still from the beta version and will be updated.
    https://github.com/matomo-org/wp-matomo/pull/218

    • This reply was modified 1 year, 11 months ago by Findus23.
    Plugin Author Thomas

    (@tsteur)

    @benbois Apologies for that. Only one part of the readme was correctly updated but I forgot to update the other part in the description where it falsely says PHP 7.0

    The plugin would actually work perfectly fine on PHP 7.0. However, in a few months we will be releasing a new major update where we already know we will require PHP 7.2. We found it would be unfair to get many installs from users using PHP 7.0 and PHP 7.1 and then a few months later they wouldn’t be able to receive an update anymore. This is why we decided to directly require PHP 7.2 even though it would work with PHP 7.0.

    If you still want to use it in the meantime, you could technically change the value in the wp-content/plugins/matomo/readme.txt to Requires PHP: 7.0 and you could use it. However, in say 4-5 months time there will be an update requiring PHP 7.2 and you would need to make that change in the readme.txt after each update so I suppose this is not really a solution.

    If there’s any chance, it be great if you could update your PHP version considering it’s a not supported version anymore. I’m fully aware this is not always easy, and sometimes not even possible.

    Thread Starter benbois

    (@benbois)

    @tsteur, thanks for your long and clear answer.

    I agree with you about the PHP version.
    I’ll think about it but right now to test your 1st WP plugin release, I’ll by modifying the readme.txt.

    Cheers.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Does’t install with PHP 7.0.33’ is closed to new replies.