WordPress.org

Forums

[resolved] Doesn't work without typing /index.php (7 posts)

  1. dragon52x
    Member
    Posted 3 years ago #

    Hi,

    I have just installed WordPress but can't bring up the dashboard without adding index.php, ie

    "http://localhost/wordpress/wp-admin" does not work but "http://localhost/wordpress/wp-admin/index.php" does.

    ".../wordpress" gives me a file list only.

    Also, "http://localhost/wordpress" does not work at all.

    I have read docs that says from dashboard you can jump to view the site by clicking "View Site" on the administration page but I can't see that link anywhere.

    If only I am shown steps to add a page, add that page to a menu and then see the results then I can continue from there. All the docs tell you how to do one thing (add page) rather than a series of steps.

    Please help, thanks

  2. Avinash Bhageloe
    Member
    Posted 3 years ago #

    dragon52x,

    Did you put all the wordpress files in the wordpress directory folder?
    I think that something went wrong while installing wordpress.
    Run the setup again and see what u get.

    You can also check ur general settings in the back end if u can acces that. Some where in the settings. Look for the url.

    Mvg,
    Avinash Bhageloe

  3. Dion Hulse
    Lead Developer
    Posted 3 years ago #

    "http://localhost/wordpress/wp-admin" does not work but "http://localhost/wordpress/wp-admin/index.php" does.

    This screams Server config issue, It sounds like your server isn't set up to serve index.php as a "default document".

    Here's the Apache declaration you should be using (If you're the server admin):

    #
    # DirectoryIndex: sets the file that Apache will serve if a directory
    # is requested.
    #
    <IfModule dir_module>
        DirectoryIndex index.php index.htm index.html
    </IfModule>
  4. w00dnutz
    Member
    Posted 3 years ago #

    Dion, thank you for your advice. I had The same problem as dragon and your solution fixed everything.

  5. dragon52x
    Member
    Posted 3 years ago #

    Problem solved. Dion was right!
    Thanks heaps.

  6. j2langr
    Member
    Posted 3 years ago #

    I'm having the same problem dragon52x had, but I'm not a server admin and don't even know what Apache is. Any advice?

    I have WordPress installed here: callahantroop351.com/wp2

    Thanks for any assistance, as I'm lost...

  7. raul010
    Member
    Posted 2 years ago #

    thanks, dica antiga, no entanto me ajudou também!

Topic Closed

This topic has been closed to new replies.

About this Topic