Support » Plugin: Highlight Search Terms » Doesn’t work with WordPress 5.6

Viewing 5 replies - 1 through 5 (of 5 total)
  • Hi, thanks for reporting 🙂

    In fact the script does work but there is a HTML5 opacity detection failing which means search terms are now wrapped in SPAN tags instead of HTML5 MARK tags. Now, the browser does not apply the default marker background color anymore.

    This will be fixed in the upcoming release but in the mean time, please add the simple CSS rule to your Appearance > Customizer > Custom CSS:

    
    .hilite {
        background-color: yellow;
    }
    

    (replace the background color with any other if you want it to match your theme better)

    Let me know if this works for you 🙂

    Thread Starter cronwerk

    (@cronwerk)

    Thank you very much for your prompt reply.

    Unfortunately, I’ve already managed to reproduce your plugin function with a few lines of code in my theme. 🙁

    I loved your nice plugin and was very happy with it. But 7 lines of code is better than 24.3 kb of plugin code. And I removed the plugin.

    Excuse me. I am so sorry! 🙁

    Thread Starter cronwerk

    (@cronwerk)

    The code you suggested works! Thank you!

    I decided that your plugin is better than the theme hook and installed the plugin again. It’s better to have a professional developer keep the plugin up to date than I forget about the hook and get glitches.

    But 7 lines of code is better than 24.3 kb of plugin code. And I removed the plugin.

    I totally agree 🙂

    Thread Starter cronwerk

    (@cronwerk)

    Unless 7 lines of code land a surprise left hook.
    In short, your 24.3 kb is better than my 7 lines of code. 🙂

    Thank you for your plugin!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Doesn’t work with WordPress 5.6’ is closed to new replies.