Support » Plugin: Next Active Directory Integration » Doesn’t work with Synology AD (SAMBA)

  • rrinzema

    (@rrinzema)


    Doesn’t work when using a Synology NAS as LDAP/AD server. Error: Creating adLDAP object failed. Bind to Active Directory failed. Check the login credentials and/or server details. [AD: Strong(er) authentication required] [AD error code: 8]. or error code -1, depending on which config is chosen.
    Probably a Synology problem, still: too bad!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author schakko

    (@schakko)

    As you have written, this is not a problem of NADI: Samba/OpenLDAP is not supported. You can try the solution at https://superuser.com/questions/1358796/ldapsearch-stronger-authentication-required-transport-encryption-required as it seems to be a configuration issue.

    Plugin Author schakko

    (@schakko)

    Just a quick follow up: In NADI you have to select “STARTTLS” if you encounter the error “Strong(er) authentication required” when trying to connect to Samba.

    Hi rrinzema . Were you able to make this work ? So NADI + “Synology Directory Server”. If yes, I would be interested to know how you did

    Thread Starter rrinzema

    (@rrinzema)

    No, still doesn’t work. Seems to get even worse: before making the settings NADI tells you to test the AD connection. But… before being able to test, you have to make the settings. Catch-22 I’m afraid.
    I don’t think this will ever work.

    Thanks for your answer.

    But : hmmm. My contact person @ the “NADI Company” informed me they have a customer who made it work. I thought it might by you, but apparently not. I have asked him to bring me in contact with that customer. I hope he will do tomorrow.

    I’m trying to make this working since several weeks now. Spending many hours. But I have the feeling I’m near to the solution. Looks for me the clue is to how to define the “Base DN”. In my DSM-ControlPanel my NAS has domain-name (example) “MyNAS.LOCAL”. So I have set, in NADI, the Base DN as : “dc=MyNas,dc=LOCAL”.

    But I still have the error-message 🙁

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this review.