WordPress.org

Forums

WP Publication Archive
Doesn't work with sub-directory WP installs (4 posts)

  1. sadhaka
    Member
    Posted 1 year ago #

    This doesn't seem to work with my WP installed into a subdirectory from the site root, as the links behind "view" and "download" include the full path, including the subdirectory name, whereas the rest of the site doesn't.

    Any quick fix for this?

    http://wordpress.org/plugins/wp-publication-archive/

  2. dilasso
    Member
    Posted 1 year ago #

    i have the same issue.
    http://wordpress.org/support/topic/updated-to-30-cant-view-or-download-goes-to-page?replies=20

    there is no reply to this issue since month!

  3. shivaji
    Member
    Posted 1 year ago #

    Same issue here.

  4. tmacholz
    Member
    Posted 1 year ago #

    I figured this out. I dug around in the plugin files, and found where it was referencing the wordpress core files instead of the site address.

    Here's what I did:
    In the class.wp-publication-archive.php file on line 77, change site_url to home_url. From what I understand, home_url is your domain, and site_url is where you core files are located.

    See this for more info.

    Hope that helps. Not a great idea to mess with plugin files in case of updates, but hopefully this will be fixed in the next release.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WP Publication Archive
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags

No tags yet.