Support » Plugin: Smart Archives Reloaded » Doesn't work with php 7, call for developer I know the issue

  • After updating to php 7 I have a issue and my hosting provvider tried to help me.

    This is his solution

    “There is a class defined: SAR_Settings which extends the class: scbAdminPage

    And in both of the classes SAR_Settings and scbAdminPage there is the same function: “validate”. However in the scbAdminPage class the function arguments are different than the one in the SAR_Settings and that triggers the warning as in PHP 7.0 the arguments should be the same for the 2 functions.

    So if you want to get the problem resolved fully contact the developer of smart-archives-reloaded and provide him with the above information regarding the PHP 7.0 version and the defined classes. Once you provide him with the information he should be able to adjust the plugin code for PHP 7.0 and release an update of the plugin which should resolve the warning that you are getting.”

    So, there is need a free developer that resolve it.

    The plugin is on GPL License.

    Please who could help us?
    Thanks

    https://wordpress.org/plugins/smart-archives-reloaded/

Viewing 6 replies - 1 through 6 (of 6 total)
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Doesn't work with php 7, call for developer I know the issue’ is closed to new replies.