Support » Plugin: Comment Mail » doesn't work with P2 theme

  • I like that this plugin organizes all the subscriptions in one place and I like how it can auto-subscribe authors when they post. That much works, but when a user comments on my site it doesn’t subscribe them. I tried disabling the confirmation email and it still didn’t work.

    https://wordpress.org/plugins/comment-mail/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Raam Dev

    (@raamdev)

    @keytastic What do you have set for the Auto-Confirm settings? Comment Mail → Config. Options → Auto-Confirm Settings.

    Does the Subscriptions Event Log or Mail Queue Event Log show anything related to those users?

    Are you sure the users who commented chose to subscribe? If they chose “no, don’t subscribe” no subscription will be created.

    The settings are:

    Auto-Confirm Everyone: Yes
    All WordPress Users Confirm their Email Address? No

    I just tested a comment. Nothing showed up in the log.

    Plugin Author Raam Dev

    (@raamdev)

    @keytastic Have you tried testing this with no other plugins active and with the default Twenty Sixteen theme to rule out a theme/plugin conflict?

    I deactivated all other plugins and switched to the Twenty Sixteen theme and it worked this time. So that means it’s a theme/plugin conflict? What can I do now?

    Plugin Author Raam Dev

    (@raamdev)

    @keytastic Now I suggest re-enabling the plugins one-by-one and retesting until you find the plugin that’s causing the problem.

    Ok, I checked. It works fine with all my plugins enabled, as long as I’m not using the P2 theme (or the Mercury child theme).

    Plugin Author Raam Dev

    (@raamdev)

    @keytastic So it sounds like those themes are doing something odd with the commenting portion of the theme. You might want to check with the developer for those themes to see what might be going on.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘doesn't work with P2 theme’ is closed to new replies.