Support » Plugin: Meow Gallery (+ Gutenberg Gallery Block) » Doesn’t work with Gutenberg

  • Resolved andreassebald

    (@andreassebald)


    Hi Meow Team,

    after successfully migrating to Meow Lightbox, I wanted to try the Meow Gallery Plugin. I am using the Hueman Theme on my site. When activating the Meow Gallery Plugin I found out that it works nicely with all Galleries created with the Classic Editor (like here).

    However, galleries created with the Gutenberg Editor still show the old behaviour (like here).

    Can you please support me with that, as I really like this Plugin as well!

    Thank you very much for your support!

    Cheers,
    Andreas

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi Meow Team,

    It is even more serious as I just learned. Apparently Classic Editor galleries (as linked above) are being arranged correctly, but the Meow Lightbox doesn‘t open any longer. Is this a Selector issue?

    Cheers,
    Andreas

    Hi Meow Team,

    Sorry, it‘s me again 😉

    I just found out, that I have to convert manually the galleries created with Gutenberg into Meow galleries. Then the galleries are being displayed correctly, as shown with the first linked post in my first mail.

    However, now the Meow Lightbox doesn‘t work any longer, as well for the Gutenberg Meow galleries and the Classic galleries. For normal images the Meow Lightbox continues to work as expected, like here.

    Therefore, the title of my request should rather be: Doesn‘t work with Meow Lightbox.

    Thanks again,
    Andreas

    Plugin Contributor Thomas

    (@kywyz)

    Hello Andreas,

    Could you please send me the link of a page with the Meow Gallery where the lightbox doesn’t work?

    Best,
    Thomas

    Hi Thomas,

    For example you can look at this page (Gutenberg)

    https://www.andreassebald.de/2019/02/februar-ahr-gebirgsstelze-eisvogel/

    or at this page (Classic Editor)

    https://www.andreassebald.de/gallerie-pilzfotografie/

    Thanks for your support!

    Cheers,
    Andreas

    Plugin Contributor Thomas

    (@kywyz)

    Hello Andreas,

    Could you please remind me what your current selector is?

    Could you try to add “.mgl-gallery” if it’s not there yet?

    Best regards,
    Thomas

    Hi Thomas,

    Until now I used the selectors (to support as well Classic as Gutenberg Editors):

    .wp-block-image, .wp-block-gallery, .gallery, .wp-caption

    Adding .mgl-gallery really solved the issue!

    Thank you very much again!

    Best regards,
    Andreas

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Doesn’t work with Gutenberg’ is closed to new replies.