Support » Plugin: Apache Status & Info » Doesn’t work well on AWS Lightsail

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Hello @ykmori !
    Sorry to hear that…
    Can you, perhaps, be a little more descriptive: what doesn’t work, what are symptoms, do you have error messages, error logs, etc.?

    Thanks.

    Thread Starter ykmori

    (@ykmori)

    Hello @pierrelannoy,

    I was able to activate the Plugin, but after setting it up and restarting Apache just to be sure, the configuration is not reflected.

    $ curl -vvv -LI http://localhost/server-status?auto

    I get a 404.

    > HEAD /server-status?auto HTTP/1.1
    > Host: localhost
    > User-Agent: curl/7.64.0
    > Accept: */*
    > 
    < HTTP/1.1 404 Not Found
    HTTP/1.1 404 Not Found
    < Date: Tue, 31 Aug 2021 06:14:14 GMT
    Date: Tue, 31 Aug 2021 06:14:14 GMT
    < Server: Apache/2.4.48 (Unix) OpenSSL/1.1.1d
    Server: Apache/2.4.48 (Unix) OpenSSL/1.1.1d
    < X-Powered-By: PHP/7.4.21
    X-Powered-By: PHP/7.4.21
    < Expires: Wed, 11 Jan 1984 05:00:00 GMT
    Expires: Wed, 11 Jan 1984 05:00:00 GMT
    < Cache-Control: no-cache, must-revalidate, max-age=0
    Cache-Control: no-cache, must-revalidate, max-age=0
    < Link: <http://localhost/wp-json/>; rel="https://api.w.org/"
    Link: <http://localhost/wp-json/>; rel="https://api.w.org/"
    < Content-Type: text/html; charset=UTF-8
    Content-Type: text/html; charset=UTF-8
    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    OK.
    Can you confirm mod_status module is enabled in your apache conf and Require directive allow localhost access?

    Thread Starter ykmori

    (@ykmori)

    Yes,

    It is set up like this.
    httpd.conf

     
    LoadModule status_module modules/mod_status.so
    
    # Real-time info on requests and configuration
    Include conf/extra/httpd-info.conf

    extra/httpd-info.conf

    <Location /server-status>
        SetHandler server-status
    #    Require host .example.com
        Require ip 127
        Require local
    </Location>
    
    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    That’s sound right… Very strange.
    As I don’t know AWS Lightsail, maybe there some specificities… IPv6 maybe?
    Have you tried with Require ::1 ?

    Thread Starter ykmori

    (@ykmori)

    I’ll try it, but it’s probably v4 as it’s recorded as IPV4 in the Apache logs.

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    Just to help me to understand, do you have a menu named “reports” under the main menu “PerfOps One”? If so, what do you see?
    It can help to understand where’s the catch 🙂

    Plugin Author Pierre Lannoy

    (@pierrelannoy)

    I’m closing this issue due to inactivity. Don’t hesitate to reopen it if needed.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Doesn’t work well on AWS Lightsail’ is closed to new replies.